CA Service Management

Expand all | Collapse all

[Text_api.cfg] Error with a category which has properties

  • 1.  [Text_api.cfg] Error with a category which has properties

    Posted 06-15-2015 02:58 PM

    Hi all!

     

    I'm facing a issue, when I try to use the email_eater to open a new incident/request ticket on CA SDM 12.7.

     

    All the keywords are working fine, but, when I try to use a category, which has properties to be properly setted when an user use is open a new ticket, in my stdlog, I got this error:

     

    "AHD58009:Could not create Request. Reason: INVALID - AHD05807:One or more Properties require values."


    I tried to set the category and the properties under the [EMAIL_DEFAULTS] on "text_api.cfg":



    key_renner.JPG


    Following exactly the same syntax, which's configured on the category:


    cat_renner.png


    And then, I set all the keywords at the email body:


    renner_mail.JPG


    Is there anything that am I doing wrong?


    Could you guys, give me a light with this?


    Thanks and regards!!!



  • 2.  Re: [Text_api.cfg] Error with a category which has properties

    Broadcom Employee
    Posted 06-16-2015 10:50 AM

    I'm not sure if this applies in  your case, but if you're using 12.6 or 12.7 it's possible you may be running into this Problem:

     

    https://support.ca.com/irj/portal/kbproblem?docid=571705&productcd=USRD&problemnbr=2148&intcmp=searchresultclick&resultnum=2#properties

     

    This is resolved with the latest Cumulative patch for either release (it does not appear in 12.9 or 14.1).

     

    If this doesn't apply in your case, I wonder if the colon could be having an issue, have you tried the same test with a Property that doesn't have any special characters?



  • 3.  Re: [Text_api.cfg] Error with a category which has properties

    Posted 06-16-2015 01:43 PM

    Hi Alexander!

     

    Well, I think that you've suggested, is exactly my case...

     

    I made a test in my Homologation/Test server which has the SDM 12.9 installed, with a category that has two properties, set as mandatory, and the issue doesn't occured. The ticket was properly created and the properties were set.

     

    I'll check this patches, and continue with my tests.

     

    Thanks for the reply!

     

    Best regards!



  • 4.  Re: [Text_api.cfg] Error with a category which has properties

    Posted 08-17-2015 08:09 AM

    Hi!

     

    Update on this case (as a way to help someone): In my case, the issue was at the categorie's properties, which were created via "pdm_load", and all the properties were with a "blank space" at its final.

     

    I made the correction, by taking off the blank spaces, and then the creation of tickets, via email eater, with the properties set as mandatory, is properly working.

     

    Regards!