DX Application Performance Management

Expand all | Collapse all

APM Team Center is showing bad performance

Jump to Best Answer
  • 1.  APM Team Center is showing bad performance

    Posted 06-15-2018 10:01 AM

    We're experiencing slow performance on TeamCenter, sometimes it takes up to 20-30 secs to view groups of components in the map.

    According to Ca documentation:

    Some of the Top 5 most important new metrics for APM Team Center are:

    1. Metric Name: Number of Active Workers Metric Path:

    Enterprise Manager|ApplicationTriageMap:Number of Active Workers What does it measure: Indicates how many threads are currently used from common thread pool of APM Team Center. It can point to overloading issues. The maximum value is 8 and it should be below 2 or 3.

    2. Metric Name: Database:Average Response Time (ms) Metric Path:

    Enterprise Manager|ApplicationTriageMap|Database:Average Response Time (ms) What does it measure:
    Indicates what is the average time of data processing in APM Database for APM Team Center.
    It can point to a bad APM Database condition.

    3. Metric Name: REST API:Average Response Time (ms) Metric Path:

    Enterprise Manager|ApplicationTriageMap|REST API:Average Response Time (ms) What does it measure:
    Indicates what's the average response time of all REST API resources for APM Team Center User Interface It can point that users are affected by a slow backend. Values under 1000ms (1s) are fine, for more than 5000ms, investigate REST API:Concurrent Invocations and REST API:Responses Per Interval to determine if the system is overloaded by requests.

    4. Metric Name: Database:Edge Count Metric Path:

    Enterprise Manager|ApplicationTriageMap|Database:Edge Count What Does It Measure:
    Indicates how many dynamic changes we are tracking for topology of ATC in APM Database. It shows a size of environment. It grows up continuously because the Database stores expired entities as well.

    5. Metric Name Ontology engine:Average Process Time (ms) Metric Path:

    Enterprise Manager|ApplicationTriageMap|Ontology engine:Average Process Time (ms) What Does it Measure: Indicates what's the average time of processing incoming static and dynamic topology changes for ATC. It can point to a problem with processing of changes. There can be some peaks, but average values should be much lower.

     

    So we're guessing it's a database issue, as anyone experienced this kind of behaviour? What can we do in order to increase the performance on the database side ? We're attaching the images on a 7 day scale and you can see the degradation of the database as we add more and more correlation in the appmap.

     

     

    Attachment(s)



  • 2.  Re: APM Team Center is showing bad performance

    Posted 06-15-2018 10:43 AM

    What version of APM are you using?



  • 3.  Re: APM Team Center is showing bad performance

    Posted 06-15-2018 10:45 AM

    Version 10.7.0 Release 10.7.0.45



  • 4.  Re: APM Team Center is showing bad performance
    Best Answer

    Posted 06-15-2018 02:11 PM

    You may be having a performance issue possibly due to an overloaded cluster.  Best bet would be to open a case and upload the logs directories from all EM's in the cluster.



  • 5.  Re: APM Team Center is showing bad performance

    Posted 06-15-2018 06:37 PM

    Tmcmm93

    Can you provide Xms and Xmx value from your ATC /teamcenter Introscope_WebView.lax file?



  • 6.  Re: APM Team Center is showing bad performance

    Posted 06-17-2018 10:01 AM

    Dear Tiago:

        Did you open the case as Matt suggested? Or provide the files as Junaid suggested?

       You are running APM 10.7.0.45 which is 10.7 GA . Running APM 10.7.0 SP 1 (See other Community posts )  may resolve some of these issues. Review the Readme to see if the fixes apply.

    Thanks

    Hal German



  • 7.  Re: APM Team Center is showing bad performance

    Posted 06-18-2018 05:09 AM

    I've attached the both .lax files of the mom/webview cluster.
    Thanks for the help , I might open a case .



  • 8.  Re: APM Team Center is showing bad performance

    Posted 06-18-2018 09:26 AM

    you dedicated 4GB of heap size to webview process. how much  total physical memory do you have. if you have 16 GB physical try to assign 10 GB to heap and restart webview. Also do the same thing for MOM heap size also.



  • 9.  Re: APM Team Center is showing bad performance

    Posted 06-18-2018 06:01 PM

    As of 10.7 we now formally published 4GB as the recommended Max Heap for WebView, although that also applies to earlier 10.x releases: Hardware Sizing and Performance - CA Application Performance Management - 10.7 - CA Technologies Documentation 

    As already mentioned the symptoms described here seem to be due to the database or possibly a MOM performance problem when accessing the database.



  • 10.  Re: APM Team Center is showing bad performance

    Posted 06-18-2018 07:29 PM

    Hi Tiago,

    There are some "Performance" & "MOM"/"EM" issues listed as Resolved in 10.7 SP1 so so applying the 10.7 SP1 Hot Fix 10.7.0-HF08 might be worth doing to see if there is any change in behaviour.

    Announcing the availability of CA APM 10.7 SP1 - CA Application Performance Management - 10.7 - CA Technologies Document… 

    Regards,

    Lynn



  • 11.  Re: APM Team Center is showing bad performance

    Posted 06-19-2018 04:49 AM

    Thanks for your advice Lynn I'll check if we can apply the hotfix asap



  • 12.  Re: APM Team Center is showing bad performance

    Posted 06-22-2018 09:18 AM

    Hi Tiago,

    I recently updated this KB that covers most of the common issues and best practices on the EM server side.

    I suggest you to check and implement all these recommendations.

     

    Introscope Enterprise Manager Troubleshooting and - CA Knowledge 

     

    I hope this helps,

    Best Regards,

    Sergio