DX Application Performance Management

 View Only
  • 1.  CA APM Historical data

    Posted Dec 11, 2018 04:34 AM

    Hi Team

    When we export the historical metric data to csv the resolution time differs.

    for eg: we want the resolution time to be 1 minutes for the time window of 7 days

    how can I achieve this,please guide me through this



  • 2.  Re: CA APM Historical data

    Broadcom Employee
    Posted Dec 17, 2018 08:56 AM

    CLW Command Reference - CA Application Performance Management - 10.7 - CA Technologies Documentation    


    Dear Imran;

    You didn't say whether you used APM SQL, Rest API, or CLW. So I will take CLW. You can set  the time period and resolution . See the above link



    Hal German

  • 3.  Re: CA APM Historical data

    Broadcom Employee
    Posted Dec 17, 2018 08:57 AM

    Dear Community:

    Do you have other suggestions?



    Hal German

  • 4.  Re: CA APM Historical data

    Broadcom Employee
    Posted Dec 19, 2018 05:09 AM

    I think I have seen the behavior before, do you have the same incorrect result if you select for the past 2 or 3 days for example?

  • 5.  Re: CA APM Historical data

    Posted Dec 19, 2018 05:15 AM

    Hi SergioMorales

    Yes the resolution times does not appear for 1 minute for 2 or 3 days.

    is this because the amount of data is high?



  • 6.  Re: CA APM Historical data
    Best Answer

    Broadcom Employee
    Posted Dec 19, 2018 06:33 AM

    I am afraid, I can't find the reference, but I have  done a quick test using latest 10.7 version and I don't have any issue, I get the right data exported.



    1) Try to reduce the query, in my case I used this one


    java -Xmx512M -Duser=Admin -Dpassword= -Dhost=localhost -Dport=5001 -jar CLWorkstation.jar get historical data from agents matching ".*Custom Metric Agent.*" and metrics matching ".*Enterprise Manager\|GC Heap:Total \(mb\).*" between 11/30/18 and 12/6/18 with frequency of 60 seconds > xx.txt


    2) It could be a timeout issue, read this

    How to increase the timeout for APM command line w - CA Knowledge 


    3) Enable VERBOSE in the EM properties file and run the query again, check if you get any error or exception, it will help you further troubleshoot the issue. If this is a cluster see if collectors are getting disconnected.




    The above is a hot property so there is not need to restart the EM, you need to wait 60 seconds.


    You might need to enable querylog to further troubleshoot the issue.


    4) Try to use APMSQLserver, I think I sent you an example in the past.



  • 7.  Re: CA APM Historical data

    Posted Dec 31, 2018 10:30 AM

    You might want to check your smart stor period tier settings to see if you are keeping 1 minute data for seven days.








    In our case, we keep 15 second resolution for 7 days.