DX Application Performance Management

Expand all | Collapse all

EPAgent - Some metrics are not displayed on WebView

Jump to Best Answer
  • 1.  EPAgent - Some metrics are not displayed on WebView

    Posted 08-14-2018 06:32 PM

    Hi, we've deployed an EPAgent in a linux server. It was working fine for few days. All the xml sent from a python script were added ok and we see it on "CA WebView" -> Investigator -> Metric Browser.

    Yesterday, I modified the python script to create two metrics inside the XML to be sent for each meassure in the server.

     

    {"type": "LongCounter", "name": "AAAA|BBBBBBB|CCCCC.DDDDDDD:concurrency", "value": "12"},

    {"type": "LongCounter", "name": "AAAA|BBBBBBB|ZZZZZZ.DDDDDDD:concurrency", "value": "12"},


    As you can see, only change a little part of the name.


    When we send 20 metrics inside an XML request (10 meassures duplicated with the name changed), EPAgent response says:

    {"validCount":20}

    But we only see 10 new metrics on WebView. Only the originals.


    XML was tested and it's OK.
    We've does a test only sending the originals and all were added.
    After that, We've sent the same XML changing CCCCC to ZZZZZZ. The response from server says "validCount 10". We've verified on WebView, the path does not exist and the metrics does not there.

     

    could you help us?

     

    BTW, we are thinking issue could be related to the number of metrics that we already have inside the EPAgent. Has EPAgent a limit of metrics to store?



  • 2.  Re: EPAgent - Some added metrics does not displayed on WebView

    Posted 08-14-2018 06:34 PM

    In adition, the agent display "Metrics under this branch: 8060"



  • 3.  Re: EPAgent - Some metrics are not displayed on WebView
    Best Answer

    Posted 08-15-2018 10:33 AM

    Hello,

     

    This could just be a clamping issue i.e. no new metrics are able to be sent by the agent or received by the EM.

     

    To check the agent clamp open the investigator and look to see if there is a red 'C' through the agent icon also you and expand the branch

     

    Custom Metric Host (virtual)
      - Custom Metric Process (virtual)
         - Custom Metric Agent (virtual)(collector_host@port)(SuperDomain)
            - Agents
               - Host
                  - Process
                      - AgentName
                      
    and then looks at the values for                  

     

     - Historical Metric Count
     - is Clamped
     - Metric Count
     - Raw Metric Count
     
     
    To check the EM clamp open the investigator and expand the branch

     

    Custom Metric Host (virtual)
      - Custom Metric Process (virtual)
         - Custom Metric Agent (virtual)(collector_host@port)(SuperDomain)
            - Enterprise manager
               - Connections
                      
    and then looks at the values for                  

     

     - EM Historical Metric Clamped
     - EM Live Metric Clamped
     - Number of Historical Metrics
     - Number of Metrics

     

    You can also check the APM Status console for evidence of clamped agents

     

    hope this helps

    Mike



  • 4.  Re: EPAgent - Some metrics are not displayed on WebView

    Posted 08-15-2018 01:39 PM

    Hi Mike, thanks for yor message. 

    It's like you said, the agent is clamped. 

     

    INFO: Looking for mandatory OSGi service dependency for bean [sysHealthNotificationManagerOsgi] matching filter (objectClass=com.wily.apm.em.monitor.support.clamp.ISystemHealthNotificationManager)
    7/23/18 12:02:00.309 PM ART [WARN] [PO:WatchedAgentPO Mailman 6] [Manager.Agent] The Agent ****** is exceeding the per-agent metric clamp (current=52225, max=50000). New metrics will not be accepted

    It's a new concept for us. I am reading some pages about clamp and limits.

     

    thanks for your time.