DX Application Performance Management

Expand all | Collapse all

MQ Agent not showing mq metrics

Jump to Best Answer
  • 1.  MQ Agent not showing mq metrics

    Posted 11-25-2017 11:35 AM

    Hello, I am trying to monitor MQ. Followed the 3 instructions here https://docops.ca.com/ca-apm/10-5/en/extending/ibm-websphere-mq/configure-mq-agent#ConfigureMQAgent-ConfiguretheMQMonitortomonitorWebSphereMQQueueManagers

     

    Have MQ 7.5 here so installed the MQAgent on my EM server, copied the required libs from mq server, set the mq host and port and started using startMQMonitor.

    I am able to see the agent on EM metric tree but it is only showing metrics from the host and from the agent, nothing related to the queues, also no log messages (turned on some mq logs that were commented out and set them to debug, but no success). Am I missing something? Any other steps required? Any ideas?



  • 2.  Re: MQ Agent not showing mq metrics

    Posted 11-25-2017 01:23 PM

    You get copies of all of the MQ libraries needed to make the agent work properly?



  • 3.  Re: MQ Agent not showing mq metrics

    Posted 11-26-2017 07:54 PM

    Hello,

    If you still have a problem after Hiko's suggestion does the MQMonitor agent log show any queue connection error or other errors?

    For enabling DEBUG in agent log these are the only 2 property changes needed: 

    log4j.rootLogger=DEBUG, logfile
    log4j.logger.IntroscopeAgent=DEBUG, logfile

    If no errors perhaps you have a metric clamp type of problem on the Enterprise Manager?

    Cluster Supportability Metrics - CA Application Performance Management - 10.5 - CA Technologies Documentation 

     

    Hope it helps

     

    Regards,

     

    Lynn



  • 4.  Re: MQ Agent not showing mq metrics
    Best Answer

    Posted 11-27-2017 09:14 AM

    Hi,

    Is it a remote setup? Please check the MQ permission.

    https://support.ca.com/us/knowledge-base-articles.TEC1378823.html

    Thanks.



  • 5.  Re: MQ Agent not showing mq metrics

    Posted 11-29-2017 07:38 AM

    Since you are seeing some agent metrics, that means the base agent is communicating with the EM-Collectors, and the issue more than likely is your connection to the queue manager.

     

    From the MQ agent log, you should see the following:

     

    10/24/17 10:55:24 AM EDT [INFO] [com.wily.powerpack.websphereMQ.agent.MQMonitor.MQMonitor] Processing MQMonitor.properties file.

     

    Then there is a block of INFO messages that have the IntroscopeAgent.Properties.  Within the sea of messages there should be a "java.class.path="

    10/24/17 10:55:24 AM EDT [INFO] [IntroscopeAgent.Properties] java.class.path=MQMonitor.jar:./lib/Agent.jar:./lib/jline-0.9.94.jar:./lib/javax.jms-api-2.0.jar:./lib/com.ibm.mq.pcf-6.1.jar::./lib/com.ibm.mq.jar:./lib/connector.jar:./lib/ConfigManagerProxy.jar:./lib/com.ibm.mqjms.jar:./lib/dhbcore.jar:./lib/j2ee.jar::::./lib/ibmjsseprovider2.jar:.

     

    Then the JVM version

    10/24/17 10:55:24 AM EDT [INFO] [IntroscopeAgent.Properties] java.fullversion=JRE 1.8.0 IBM J9 2.8 Linux amd64-64 Compressed References 20170722_357405 (JIT enabled, AOT enabled)

     

    The next section should be the MQProperties section with the Queue Manager configuration from the MQMonitor.properties file.

     

    Next the base agent is echoing the properties for the IntroscopeAgent.agent

    The agent, once completed reading the properties will connect to the MOM, get a collector list and then disconnect from the mom and reconnect to a collector.

    Connected to <collector>,com.wily.isengard.postofficehub.link.net.DefaultSocketFactory in allowed mode.

     

    Right below that there should be two INFO messages that establishes the connection to the queue manager:

    10/24/17 10:55:26 AM EDT [INFO] [com.wily.powerpack.websphereMQ.agent.MQMonitor.ConfigurationInstance] Connection is successful using channel SYSTEM.AUTO.SVRCONN
    10/24/17 10:55:26 AM EDT [INFO] [com.wily.powerpack.websphereMQ.agent.MQMonitor.ConfigurationInstance] Start Monitoring: namelist <queuemgr><host>:5565
    Configuration Instance Name=<queuemgr><host>
    Channel=SYSTEM.AUTO.SVRCONN
    Character Set=819
    Model Queue=SYSTEM.DEFAULT.MODEL.QUEUE
    SSL=disable
    CipherSpec=
    DelayTime=600 seconds
    Report Static Freq=20
    Filter static metrics=true
    Filter Dynamic Queues=false
    Include only Regex=.*

     

    If you don't see these messages, then the agent was not able to connect to the queue manager in order to subscribe to the model queue for MQ metrics.

     

    Assuming you are not seeing a "Connection is successful" message there can be a few issues:

     

    1.  Firewall / Network - the agent host is not able to get to the MQ host.  Check with your network/firewall admins to see if they can tell if the communication from your agent host is able to get to the MQ host

     

    2.  MQ permission - your user that the agent is running under, let say "apmmq" has to exist on the MQ host and that user has to have permissions

    In the MQ agent directory there are a few files that might help with this.  The WILYRACF.JCL and the /properties/MBMonitorJMSQueues.mqsc"

     

    3.  Java version - Double check to see if you are using an IBM or an Oracle JVM.  I've not tried to connect to MQ with an Oracle JVM, but it might be different.

     

    4.  Communication JARS - You need all of these JARs and most are from the MQ installation (make sure when you transfer them you use binary instead of text)  The j2ee.jar and I think the connector.jar are from an WebSphere application instance that communicates with MQ.  Now with MQ (IIB) v10 the method to connect changed so you need to insure that your MQ agent version supports the MQ version you are attempting to communicate with.

    com.ibm.mq.commonservices.jar
    com.ibm.mq.headers.jar
    com.ibm.mq.jar
    com.ibm.mq.jmqi.jar
    com.ibm.mqjms.jar
    com.ibm.mq.pcf-6.1.jar
    com.ibm.mq.pcf.jar
    ConfigManagerProxy.jar
    connector.jar
    dhbcore.jar
    ibmjsseprovider2.jar
    j2ee.jar
    javax.jms-api-2.0.jar
    jline-0.9.94.jar

    Agent.jar

     

    Double check that all of the jars are there and you see them within the <agent home>/lib directory and that path and jar names are set correctly in the startMQMonitor.sh.

     

    Hope this helps,

     

    Billy



  • 6.  Re: MQ Agent not showing mq metrics

    Posted 11-29-2017 07:58 PM

    The issue was related to mq permission, followed the instructions on the link (tec1378823) and it worked.

    Also noticed this info was on the documentation after checking the answers here, but  there are so many instructions and information there that it is easy to get lost. That felt a lot harder than it really was.

     

    Thanks a lot for the info.

     

    Cheers