DX Application Performance Management

Expand all | Collapse all

mount agent fails

Jump to Best Answer
  • 1.  mount agent fails

    Posted 09-18-2015 05:32 AM

    hello guys

    I have to mount an agent to recover metrics back to 10 days ago

    But when I try i get the following error

     

    9/18/15 11:00:56.353 AM CEST [ERROR] [PO:main Mailman 4] [Manager.MessageService] Exception: com.wily.util.exception.UnexpectedExceptionError: com.wily.util.exception.UnexpectedExceptionError calling method: com.wily.isengard.messageprimitives.service.MessageServiceCallMessage: {com.wily.introscope.spec.server.beans.agentservice.IAgentService.mountHistoricalAgent, v1, [key: 6109651179508948354, po: Workstation_8154.client_main, agentxxxxx]}

     

    Anybody can sugegst how to solve this?

     

    Thank you



  • 2.  Re: mount agent fails
    Best Answer

    Posted 09-18-2015 06:16 AM

    Hello,

     

    This seems to be like MOM is receiving some exception when it is trying to send this(mountHistoricalAgent) message to collectors in cluster.

     

    So are all your EM's connected to cluster and no smartstor accessible issues? Can you also check if your EM's are running on high capacity? Can you check for high resource(heap,CPU, GC) capacity or high metrics capacity? Can you check for live or historical metrics count capacity as well?

     

    Thanks,

    Karthik



  • 3.  Re: mount agent fails

    Posted 09-18-2015 07:16 AM

    You are great!

    I solved rebooting the collector. System phereaps could not read SmartStore historical

    Thanks.