DX Application Performance Management

Expand all | Collapse all

AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

  • 1.  AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Posted 02-15-2016 07:31 PM

    We are trying to get the 10.1.0.15 agent running in WebSphere 7.0 JVMs and we seem to get the Autoprobe to restart over and over, filling up the File System. In the Introscope Agent log I see pages and pages of:

     

    2/15/16 05:14:15 PM EST [INFO] [IntroscopeAgent.Agent] AutoProbe has reloaded all directive configuration.  This is because a change to a directive configuration file was detected.
    2/15/16 05:14:22 PM EST [INFO] [IntroscopeAgent.Agent] Detected Changed Directives
    2/15/16 05:14:22 PM EST [INFO] [IntroscopeAgent.Agent] Processing all classes for Dynamic Instrumentation.
    2/15/16 05:14:23 PM EST [INFO] [IntroscopeAgent.Agent] Successfully Re-defined Class org.springframework.aop.framework.ReflectiveMethodInvocation.
    2/15/16 05:14:23 PM EST [INFO] [IntroscopeAgent.Agent] Finished Processing All classes for Dynamic Instrumentation.
    2/15/16 05:46:15 PM EST [INFO] [IntroscopeAgent.Agent] AutoProbe has reloaded all directive configuration.  This is because a change to a directive configuration file was detected.
    2/15/16 05:46:22 PM EST [INFO] [IntroscopeAgent.Agent] Detected Changed Directives
    2/15/16 05:46:22 PM EST [INFO] [IntroscopeAgent.Agent] Processing all classes for Dynamic Instrumentation.
    2/15/16 05:46:23 PM EST [INFO] [IntroscopeAgent.Agent] Finished Processing All classes for Dynamic Instrumentation.
    2/15/16 06:05:15 PM EST [INFO] [IntroscopeAgent.Agent] AutoProbe has reloaded all directive configuration.  This is because a change to a directive configuration file was detected.
    2/15/16 06:05:23 PM EST [INFO] [IntroscopeAgent.Agent] Detected Changed Directives
    2/15/16 06:05:23 PM EST [INFO] [IntroscopeAgent.Agent] Processing all classes for Dynamic Instrumentation.
    2/15/16 06:05:23 PM EST [INFO] [IntroscopeAgent.Agent] Finished Processing All classes for Dynamic Instrumentation.

     

    We were originally running the spring field pack but took that out an went back to the older SpringWS Field Pack. All that did was slow down the restarts...

     

    I will probably open a ticket tomorrow....



  • 2.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Broadcom Employee
    Posted 02-15-2016 08:22 PM

    Hi Steve,

    It looks like that is due to Dynamic Instrumentation which is enabled with the OOTB agent profile

    introscope.autoprobe.dynamicinstrument.enabled=true

    Perhaps you had it disabled in previous version?

    For further details please see: Dynamic Instrumentation Properties

     

    If no help please raise a support case & my colleagues in NAM Support will assist

     

    Thanks

     

    Lynn



  • 3.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Posted 02-16-2016 10:24 AM

    They were using a 9.7.0.27 agent so the Dynamic Instrumentation properties were still turned off by default...

     

    I have having them install a 10.0 agent to see if Dynamic Instrumentation works there...



  • 4.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Broadcom Employee
    Posted 02-16-2016 10:56 AM

    Thanks Steve. We await your update on 10.x agent test



  • 5.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Posted 02-16-2016 06:42 PM

    Putting in the 10.0.0.12 with the most up-to-date Spring Field Pack stop the excessive restarting of Autoprobe and thus the excessive logging in both logs...especially the AutoProbe since it is not replicating all the pbds over and over again.

     

    I am opening a support case since I do not want to turn off the Dynamic Instrumentation at the get go since I was hoping that this agent would be a production candidate...something has changed between 10.0 and 10.1 in the way it is handling Dynamic Instrumentation,

     

    Will post the support number here...



  • 6.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Broadcom Employee
    Posted 02-16-2016 07:03 PM

    Thanks Steve

    I found a similar recent case for 10.0/IBM JVM 1.6 which also had repeated entry point detection (uses dynamic instrumentation) symptoms in the logs

    [IntroscopeAgent.EntryPointDetection] Initial Entry Point Candidate

    [IntroscopeAgent.EntryPointDetection] Removed Inactive Frontend Candidate

    If you see similar messages our customer found that using the NoRedef profile/AgentNoRedefNoRetrans.jar fixed it although you could try to disable entry point detection if you are happy to do that? i.e. introscope.agent.deep.entrypoint.enabled=false

    Entry point detection is enabled by default in both 10.0 & 10.1 so that still does not explain why you only see the problem in 10.1 !

     

    Regards,

     

    Lynn



  • 7.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Posted 02-16-2016 07:16 PM

    00313000: Autorprobe restarted is the support case

     

    I uploaded Profile, AutoProbe and IntroscopeAgent logs from both versions. As I mentioned, the 10.0 agent is using the most current Spring Field pack and custom pbd and I think by the time I took the 10.1 logs we had removed all Spring and Custom PBDs...

     

    I had seem some of the EntryPoints messages  in the logs but most of the Agent logs were the ones I put in the discussion above...pages and pages of those....

     

    Thanx for your help...



  • 8.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Broadcom Employee
    Posted 02-17-2016 08:49 AM

    Hi Steve:

    I see Kulbir is working the case so you are in good hands and will let the case take its course

     

    Thanks

    Hal German



  • 9.  Re: AutoProbe Seems to be restarted over and over in WebSphere Java Agent 10.1

    Broadcom Employee
    Posted 02-16-2016 08:10 AM

    Hi Steve:

       Please let us know if you opened the case or have any additional questions. Was Lynn's response helpful?

      Thanks

      Hal German