DX Application Performance Management

Expand all | Collapse all

Creating Metric Grouping Takes Too Much Time at Investigator

  • 1.  Creating Metric Grouping Takes Too Much Time at Investigator

    Posted 10-07-2015 05:10 AM

    Hi,

     

    When I try to create a new mertic grouping from the ınvestıgator ın the worksratıon (rıght-clıck menu), it takes about 2 and 3 minutes to create it at the module. I have observed that it also increases the CPU usage 10 times more for these 2 minutes time period (from about 1% to about 12%). Although we don't have too many metrics ın the group (about 30), and we have allocated 10GB heap to the EM (standalone). In the EM overview all metrıcs are fıne, no errors or warnıngs ın the EM-log and EM DB is seperated. While it tries to create new grouping introscope can not retrieve any data on live mode - all workstatıon wındows freeze. I am using EM version 10.  Do you have any idea about the cause?



  • 2.  Re: Creating Metric Grouping Takes Too Much Time at Investigator

    Posted 10-07-2015 09:47 AM

    Hi Can,

     

    there have been similar incidents. Please open a support ticket.

     

    Ciao,

    Guenter



  • 3.  Re: Creating Metric Grouping Takes Too Much Time at Investigator

    Posted 10-07-2015 10:55 AM

    Hi Can,

     

    As Guenter stated, please open a support issue so that it can be investigated.

     

    It could be a few things to start off with:

     

    1. Since are you using a standalone EM, if you are using webstart workstation, then the UI will use the MOM's heap.  If you are using workstation thick client, that has its own heap set and the default is generally very small (either 256 or 512 mb).  So I would verify which one you are using.

    2. Possibly the regex for the new metric group is too broad and trying to take in too many metrics at once.

    3. Possibly a slowness in communicating with Smartstor.

    4. Possible EM is taking up a lot of resources.  A list of resources that the EM has at runtime are metric groups, calculators, alerts, reports, anything inside a Management Module.  Also each Module takes up resources as well.

    5. Possible other 3rd party software running on the same server, i.e. antivirus

     

    You can observe if this is a UI issue or a backend issue by recreating the metric group in Webview or if you're using webstart, use the workstation thick client (or vice versa).

     

    You can also see if this is a regex issue by creating a metric group for 1 to 5 metrics.

     

    But ultimately, this can be resolved quicker by opening a Support issue.

     

    Thanks,
    Matt