DX Application Performance Management

 View Only
  • 1.  Zero packets analyzed by tim

    Posted Aug 26, 2016 06:04 PM

    Hey guys, I have just installed tim, mirroed traffic to the interface I have enabled but when I check Tim packet Statistics I see  50k+  packets captured but zero packets analyzed and zero dropped. I tcpdumped the traffic that was mirroed and I see http traffic.


    Am I missing something here? I guess I should be seeing packets analyzed/Bytes Analyzed even before I connect and enable this tim to a CEM, right?

  • 2.  Re: Zero packets analyzed by tim

    Broadcom Employee
    Posted Aug 26, 2016 06:19 PM

    What is the APM version?


    Which OS version for the TIM?


    Did you apply all of the necessary prerequisite files to the OS before installing the TIM?

  • 3.  Re: Zero packets analyzed by tim
    Best Answer

    Broadcom Employee
    Posted Aug 27, 2016 10:40 AM

    I believe the TIM needs to be enabled to help with troubleshooting. Please do so.


    Other thoughts:


    In addition to what Hiko requested:

    Is this a Tim only or TIM/MTP


    There are a variety of knowledge documents on this as well as my Tim Success Guide part 1 that can be found on this community. Please look through those for clues


    Things to check


    - MTP Hardware filters/CEM Web Server Filters

    - interfacefilter.xml is correct

    - balancer.cnf is correct

    - Messages in all tim logs


    Please report back or open a case

  • 4.  Re: Zero packets analyzed by tim

    Broadcom Employee
    Posted Aug 28, 2016 07:09 PM

    Based on the fact that packets are captured but 0 analyzed it sounds most likely MTP Hardware Filters or CEM Web Server Filters as suggested by Hal.

    However if it is a standard TIM (no MTP) that you have not yet enabled from CEM then in theory you should not have any web server filters propagated to the TIM.

    If standard TIM it may be related to integration of tim process with the apmpacket process (captures the data)

    Best debug as follows:

    Under TIM Settings increase MaxLogSizeInMB to 200

    Under TIM trace options just enable:

    Trace HTTP components
    Trace connections
    Trace SSL errors


    • Stop TIM
    • Delete files /opt/CA/APM/tim/logs/timlog*.txt 
    • Start TIM and after a few minutes check the new /opt/CA/APM/tim/logs/timlog*.txt  files from startup
    • If standard TIM also check file: /opt/CA/APM/apmpacket/logs/apmpacketlog.txt


    Hope it helps.





  • 5.  Re: Zero packets analyzed by tim

    Posted Aug 29, 2016 09:55 AM

    Running 10.3 TIM only (no MTP) on a Red hat 6.7. Apparently all libs were installed (as it didnt complain during install).


    Ill check the material you guys suggested and logs after applying those settings.


    Thanks for now!

  • 6.  Re: Zero packets analyzed by tim

    Broadcom Employee
    Posted Aug 29, 2016 10:30 AM


    Since you are going to investigate the two provided next steps and there are no followup questions, I will mark as answered. Please feel free to continue posting followup information and resolutions from your investigations. Or if you have any followup questions



    Hal German