DX Application Performance Management

 View Only
Expand all | Collapse all

.NET AGENT not picking up applications running under 2.0 framework

  • 1.  .NET AGENT not picking up applications running under 2.0 framework

    Posted Nov 11, 2015 02:58 PM

    Hi everyone,  I have installed  Introscope 10.0 .NET Agent on a Windows 2012 64 bit server running IIS.  I am trying instrument an application that is running on the server and the IIS application pool is set 2.0 Framework.  The Agent will not pick up the application at all.  I have restarted the server and validated everything was installed properly.  I tried a sample application and had the same issue.  Then, I switched the sample application's application pool to run under 4.0 Framework..  BINGO!  The sample application was picked up by the agent and was instrumented. When I try the application I was trying this on originally, it works fine.  The issue is needs to run under 2.0 Framework.

     

    What would cause the agent not to pick up the applications running under 2.0 Framework?

     

    BTW, I do have this setting set in the config file: com.wily.introscope.nativeprofiler.monitor.inprocsxs.multiple.clrs=v2.0.50727,v4.0.30319

     

    Thanks!

    Jeremy



  • 2.  Re: .NET AGENT not picking up applications running under 2.0 framework
    Best Answer

    Posted Nov 11, 2015 05:37 PM

    Hi Jeremy,

    Support for .NET 2.0, 3.0 and 3.5 frameworks was dropped with APM 9.7 or higher agents.

    You can deploy .NET Agent version lower than 9.7 for e.g and it should work with .NET 2.0 framework.

    If it doesn't then kindly open a support issue so we can help troubleshoot it further.

     

    For future reference please note that all our Compatibility Guides can be accessed from below location:

    CA Application Performance Management Compatibility Guides - CA Technologies

     

    Regards,

    Kulbir.