DX Application Performance Management

Expand all | Collapse all

APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

Jump to Best Answer
  • 1.  APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 01:16 PM

    I have upgraded our dev environment from v9.5.3 to v10.1 and everything else is working except the MoM is not listening on port 8081. Our prod environment is still on v9.5.3 and there the MoM is listening on port 8081. Not sure how to resolve this so posting it on the community to get some help.

     

    I think because of this I am getting the following errors on APM Team Center after I login:

     



  • 2.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:20 PM

    Hello Mparikh72,

     

    Please see below Doc in order to address your inquire:

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1881846.aspx

     

    Let us know the results.

    Gustavo.



  • 3.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:29 PM

    Hi Manish:

    Does Gustavo's note or is further assistance needed?

     

    Thanks

    Hal German



  • 4.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:34 PM

    Hallett_German I am looking into it.



  • 5.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:36 PM

    So, strgu01, I've already looked at that Doc and already have those setting configured. But if MoM is not listening on port 8081 then doesn't matter what WebView settings are b/c it will not be able to comm with MoM, right?

     

    Hallett_German



  • 6.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:44 PM

    Hello Mparikh72,

     

    Well, your mom are listening port 8081? if not make sense your comment above. In fact there are other things that may cause this above error, TeamCenter use APMDB to index so if you have any problem with your schema it can be the symptom, I could see many of them when upgrading from 9.7x to 10x.

    I would suggest you to a look under MOM logs to see if any APPMAP error is being saw, also, you can enable DEBUG mode inside the webview and see wha is going on. To finish, try to open a support ticket for a better track.

     

    Gustavo.



  • 7.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 02:48 PM

    strgu01............yes, the MoM is not listening on port 8081 so that's why I have this issue. So, need to figure out how to fix this. I'll follow-up on your suggestion and take a look at the logs.

     

    Thanks



  • 8.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 03:25 PM

    I've opened up a support case

     

    00347948: MoM Not Listening on port 8081

     

    strgu01 Hallett_German Keith.W



  • 9.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3
    Best Answer

    Posted 03-30-2016 04:00 PM

    Ok, so found the solution.

     

    need to uncomment the following section in "em-jetty-config.xml" file

    _________________________________________________________________

      <!-- Configure non-secure http listener for the Jetty Server -->

      <!-- using an extension of org.mortbay.jetty.bio.SocketConnector -->

      <!-- that doesn't throw NPE on EM shutdown -->

      <Call name="addConnector">

        <Arg>

          <New class="com.wily.webserver.NoNPESocketConnector">

            <Set name="port">8081</Set>

            <Set name="HeaderBufferSize">8192</Set>

            <Set name="RequestBufferSize">16384</Set>

            <Set name="ThreadPool">

              <New class="org.mortbay.thread.BoundedThreadPool">

                <Set name="minThreads">10</Set>

                <Set name="maxThreads">100</Set>

                <Set name="maxIdleTimeMs">60000</Set>

              </New>

            </Set>

          </New>

        </Arg>

      </Call>

    _________________________________________________________________

     

    and then restart the MoM/EM. This will enable MoM/EM to listen on port 8081.

     

    VERY IMPORTANT NOTE:

    So, along with the new WebView property that should be configured which is mentioned in this doc, I think CA also needs to add to that doc that if you are using "em-jetty-config.xml" for your MoM/EM then the above section needs to be uncommented.

     

    Thanks a lot for your helps guys, especially Keith.W

     

    strgu01 Hallett_German somad01 Hiko_Davis



  • 10.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-30-2016 09:17 PM

    Hi Manish,

    Yes I will add an update to that KB to mention the jetty file alternative.

    Typically this problem does not often arise as normally users who don't want to use the secure connector (SSL) will not enable the jetty file option in EM properties i.e. they will just use the default non-secure web server configuration running on 8081 corresponding to:

    "introscope.enterprisemanager.webserver.port=8081"

     

    Thanks,

     

    Lynn



  • 11.  Re: APM v10.1 MoM not listening on port 8081 after upgrading from v9.5.3

    Posted 03-31-2016 01:21 PM

    I am seeing more customers now having to use secure comm between EMs to comply with their internal security protocols. But to have this information as an FYI on that KB article wouldn't hurt at all, especially when/if they upgrade APM and have to add security.

     

    Thanks lyoch02