DX Application Performance Management

Expand all | Collapse all

Shutting off EPAgents Agent Components from Workstation

  • 1.  Shutting off EPAgents Agent Components from Workstation

    Posted 05-20-2015 05:15 PM

    Hi,

     

    I have come across a weird situation and I am trying to make sense of it, any light you can shed on this will be helpful.

     

    1. There are two instances of the EPAgent running on the same server, with different PID's.

    2. They have different launch times as well, but when I do a ps -ef | grep java only the PID with the most recent launch time shows up.

    3. The other PID doesnt come up at all, there is no information related to it.

    4. The agent is configured to startup with the service command start, so when the server was restarted the older instance of the agent should have gone, but it is still there and the launch time shows an older time.

    5. I tried shutting off the Agent components from the Workstation but the metrics are still coming in live. How is that possible? WHat can be done to stop that agent to report in the dashboard or creating alerts?

    6. The other confusion is, even when two instances are running, they should report the same data, but it is not. How do I troubleshoot?



  • 2.  Re: Shutting off EPAgents Agent Components from Workstation

    Posted 08-03-2015 04:08 PM

    Hi:

    I am marking this as assumed answered you did not request a follow-up over some time. Please open a new question with updated information if needing additional assistance.

      

    Thanks

    Hal German

    APM Support