Plex 2E

  • 1.  Plex and PostGres (problem with field ctid)

    Posted 03-11-2016 12:22 PM

    Hello, we know that PostGreSQL is not a supported database but one of our customer ask us to develop an application with this target database. We thought that using odbc or jdbc we can try to use it. We tried to develop some entities and Plex compiles the tables and the views. So we hope that all works correctly (now we tried to use configuration using Winc and NTODBC Server). The problems appears when we tried to read the table using BlockFetch and Checkrow, or SingleFetch. Because the  query we receive on the postgres db are added of a field named "ctid" that is not present in the views that Plex generate. The field that is an internal field of a postgres table exist and if we make the query included this field on a table it works correctly but it doesn't work on a query on the view, because the field is not included in the view. The strange fact is that BlockFetch add this field byself. We don't understand why.

    We have solved the problem using the triple VW type sys Table_access, but we think may be a limitation.



  • 2.  Re: Plex and PostGres (problem with field ctid)

    Posted 03-11-2016 03:03 PM

    this will interest you SELECT FOR UPDATE, so that allows the use of the code generated by PLEX, with other database engines.

     

    Have recreated your issue. when i run odbc trace on my machine i see the error "DIAG [42703] ERROR: column "ctid" does not exist;"

     

    Will have a quick play



  • 3.  Re: Plex and PostGres (problem with field ctid)

    Posted 03-11-2016 03:33 PM

    see this Can't access views from Base (postgres odbc) (View topic) • Apache OpenOffice Community Forum

     

    Uncheck Updatable Cursors in the ODBC setting and mine works

    Untitled.png



  • 4.  Re: Plex and PostGres (problem with field ctid)

    Posted 03-15-2016 06:47 AM

    Did this help Giandomenico?



  • 5.  Re: Plex and PostGres (problem with field ctid)

    Posted 03-15-2016 10:35 AM

    It works!!!!!

    Thank you very much George. Great Plex.