Service Virtualization

Expand all | Collapse all

Error while running the Seleium JSOn script

  • 1.  Error while running the Seleium JSOn script

    Posted 12-06-2017 02:59 AM

    Hi ,

    I have recorded a simple JSON script and created a Selenium step in CADevtest.while running I get the below error:

    The IE URL is getting launched, but it is not navigating to the URL

     

    ============================================================================
    | Error executing Selenium Script :
    {
        "type": "script",
        "seleniumVersion": "2",
        "formatVersion": 2,
        "steps": [{
            "negated": false,
            "type": "get",
            "url": {{EndPOint}}
        }]
    }
    ============================================================================
    | Step:        Selenium Script
    ----------------------------------------------------------------------------
    | Message:     {"negated":false,"type":"get","url":"*******************"} failed.
    ----------------------------------------------------------------------------
    | Trapped Exception: {"negated":false,"type":"get","url***"} failed.
    | Trapped Message:   java.lang.RuntimeException: {"negated":false,"type":"get","url******}failed.
    ----------------------------------------------------------------------------
    STACK TRACE
    java.lang.RuntimeException: {"negated":false,"type":"get","url":"****"} failed.
     at com.sebuilder.interpreter.TestRun.executeStep(TestRun.java:81)
     at com.itko.lisa.glass.SeleniumScriptExecutor.executeStep(SeleniumScriptExecutor.java:373)
     at com.itko.lisa.glass.SeleniumScriptExecutor.executeStep(SeleniumScriptExecutor.java:305)
     at com.itko.lisa.glass.SeleniumScriptExecutor.executeScript(SeleniumScriptExecutor.java:147)
     at com.itko.lisa.glass.SeleniumScriptTestNode.execute(SeleniumScriptTestNode.java:110)
     at com.itko.lisa.test.TestNode.executeNode(TestNode.java:981)
     at com.itko.lisa.test.TestCase.execute(TestCase.java:1288)
     at com.itko.lisa.test.TestCase.execute(TestCase.java:1203)
     at com.itko.lisa.test.TestCase.executeNextNode(TestCase.java:1188)
     at com.itko.lisa.editor.WalkThruPanel.prepAndExecNode(WalkThruPanel.java:1058)
     at com.itko.lisa.editor.WalkThruPanel.access$900(WalkThruPanel.java:71)
     at com.itko.lisa.editor.WalkThruPanel$10.doCallback(WalkThruPanel.java:965)
     at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
     at java.lang.Thread.run(Unknown Source)
    Caused by: org.openqa.selenium.remote.SessionNotFoundException: session null does not exist (WARNING: The server did not provide any stacktrace information)
    Command duration or timeout: 0 milliseconds
    Build info: version: '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46'
    System info: host: 'ILNC4-V22379', ip: '10.123.32.154', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_60'
    Driver info: org.openqa.selenium.ie.InternetExplorerDriver
    Capabilities [{capabilities={proxy={}, acceptInsecureCerts=false, browserVersion=11, se:ieOptions={nativeEvents=true, browserAttachTimeout=0, ie.ensureCleanSession=false, elementScrollBehavior=0, enablePersistentHover=true, ie.browserCommandLineSwitches=, ie.forceCreateProcessApi=false, requireWindowFocus=false, initialBrowserUrl=http://localhost:11523/, ignoreZoomSetting=false, ie.fileUploadDialogTimeout=3000, ignoreProtectedModeSettings=false}, timeouts={implicit=0, pageLoad=300000, script=30000}, browserName=internet explorer, pageLoadStrategy=normal, unhandledPromptBehavior=dismiss, platformName=windows, setWindowRect=true}, sessionId=1f9a0939-3132-47d3-9126-55202660efa8, platform=ANY}]
    Session ID: null
     at sun.reflect.GeneratedConstructorAccessor45.newInstance(Unknown Source)
     at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
     at java.lang.reflect.Constructor.newInstance(Unknown Source)
     at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:206)
     at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:158)
     at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:678)
     at org.openqa.selenium.remote.RemoteWebDriver.get(RemoteWebDriver.java:316)
     at com.sebuilder.interpreter.steptype.Get.run(Get.java:25)
     at com.sebuilder.interpreter.TestRun.executeStep(TestRun.java:75)
     ... 13 more
    ============================================================================



  • 2.  Re: Error while running the Seleium JSOn script

    Posted 12-08-2017 11:22 AM

    Can you check the project.config file  if it has the right  ENDPOINT  URL ?

    from the logs it say: 


    | Message:     {"negated":false,"type":"get","url":"*******************"} failed.

    url": {{EndPOint}}