Service Virtualization

Expand all | Collapse all

unable to connect to registry from workstation on changing proxy in local properties

  • 1.  unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-17-2017 02:25 PM

    I am unable to connect to devtest workstation on changing proxy in local.properties file.

    getting below error in logs

    2017-08-17 18:18:26,946Z (23:48) [ProcDlgThreadCallbk@78a38bac] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from class path resource [applicationContext-security.xml]
    2017-08-17 18:18:27,627Z (23:48) [ProcDlgThreadCallbk@78a38bac] INFO org.springframework.context.support.GenericXmlApplicationContext - Refreshing org.springframework.context.support.GenericXmlApplicationContext@10cc77b1: startup date [Thu Aug 17 23:48:27 IST 2017]; root of context hierarchy
    2017-08-17 18:18:27,842Z (23:48) [Preflighting database] INFO com.itko.lisa.gui.TestAdmin - Database preflight completed
    2017-08-17 18:18:29,155Z (23:48) [ProcDlgThreadCallbk@78a38bac] ERROR com.itko.lisa.test.LisaSecurityManager - Authentication Error
    org.springframework.security.authentication.AuthenticationServiceException: Error authenticating with username 'admin'
    at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:167)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:730)
    at com.itko.lisa.test.LisaSecurityManager.authenticateUser(LisaSecurityManager.java:686)
    at com.itko.lisa.test.LisaSecurityManager.authenticateUserFromGUI(LisaSecurityManager.java:928)
    at com.itko.lisa.gui.TestAdmin$1.doCallback(TestAdmin.java:232)
    at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
    at java.lang.Thread.run(Unknown Source)
    Caused by: retrofit.RetrofitError: 404 Not Found
    at retrofit.RetrofitError.httpError(RetrofitError.java:40)
    at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388)
    at retrofit.RestAdapter$RestHandler.invoke(RestAdapter.java:240)
    at com.sun.proxy.$Proxy2.authenticateAndAuthorize(Unknown Source)
    at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:162)
    ... 6 more
    2017-08-17 18:18:29,251Z (23:48) [AWT-EventQueue-0] ERROR com.itko.util.swing.UserMessage - Error connecting to the DevTest Registry. Error message: Error authenticating with username 'admin'
    org.springframework.security.authentication.AuthenticationServiceException: Error authenticating with username 'admin'
    at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:167)
    at com.itko.lisa.test.LisaSecurityManager.authenticate(LisaSecurityManager.java:730)
    at com.itko.lisa.test.LisaSecurityManager.authenticateUser(LisaSecurityManager.java:686)
    at com.itko.lisa.test.LisaSecurityManager.authenticateUserFromGUI(LisaSecurityManager.java:928)
    at com.itko.lisa.gui.TestAdmin$1.doCallback(TestAdmin.java:232)
    at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
    at java.lang.Thread.run(Unknown Source)
    Caused by: retrofit.RetrofitError: 404 Not Found
    at retrofit.RetrofitError.httpError(RetrofitError.java:40)
    at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388)
    at retrofit.RestAdapter$RestHandler.invoke(RestAdapter.java:240)
    at com.sun.proxy.$Proxy2.authenticateAndAuthorize(Unknown Source)
    at com.ca.dts.security.authentication.RemoteAuthenticationManager.authenticate(RemoteAuthenticationManager.java:162)
    ... 6 more

     

     

    The properties which i changed

     

    ## ==============================================
    lisa.http.webProxy.host=abc.xyz.com
    ##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]*
    lisa.http.webProxy.nonProxyHosts=localhost
    lisa.http.webProxy.port=80XX

    ## ==============================================
    ## HTTPS Proxy Server
    ## ==============================================
    lisa.http.webProxy.ssl.host=abc.xyz.com
    ##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]*
    lisa.http.webProxy.ssl.nonProxyHosts=localhost
    lisa.http.webProxy.ssl.port=80XX

     

    on commenting above properties its working fine.



  • 2.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-17-2017 05:42 PM

    What version of DevTest?

     

    Are you using HTTP or HTTPS, needs to be one or the other not both.



  • 3.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-18-2017 12:36 PM

    I am using devtest 8.4. 

     

    i am using HTTPS now but getting below error while recording

     

     

     



  • 4.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-21-2017 12:49 PM

    May i know what changes did you make in local.properties file?



  • 5.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-21-2017 01:57 PM

    ## HTTPS Proxy Server
    ## ==============================================
    lisa.http.webProxy.ssl.host=abc.xyz.com
    ##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]*
    lisa.http.webProxy.ssl.nonProxyHosts=localhost
    lisa.http.webProxy.ssl.port=80XX



  • 6.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 08-21-2017 03:52 PM

    You need to select Recorder passthru style as Proxy instead on Gateway. 

    For more details refer below discussion:

    How to test the REST with Proxy Set up in Test case  and VSE? 

    Also, for Recorder passthru style options: 

    HTTP/S Transport Protocol - DevTest Solutions - 10.0 - CA Technologies Documentation  



  • 7.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 10-30-2017 08:54 AM

    Hi Monica,

     

    issue is i am unable to connect to my local registry When i am doing above changes in my local.properties file.

     

    getting below error

     

     

     

    please let me know if more info is required.



  • 8.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 10-30-2017 09:11 AM

    Is your Registry on Derby or an external database?



  • 9.  Re: unable to connect to registry from workstation on changing proxy in local properties

    Posted 10-30-2017 09:57 AM

    it got connected but now i am getting error while starting recorder in proxy mode . can you please help me with small doubt.

     

    While in proxy mode recording where in properties file we have to add target host , target port and proxy host and port. can you help me with properties name?