Service Virtualization

Expand all | Collapse all

Update DevTest Portal URL

Jump to Best Answer
  • 1.  Update DevTest Portal URL

    Posted 03-01-2017 03:11 PM

    Hi I recently, split up the devtest portal from the registry. We are upgrading from DevTest 8.5 to 10. Previously we were using the console, and now the portal has to be introduced. Because the Portal is on a different server than the registry, the URL in the screenshot below is incorrect, when trying to access old console (port 1505). My question is, how can I update this value? Is there a property that controls this? We are using Docker, so I would like to pass it in at startup. In our environment, registry are spun up on the fly, so manually updating this string won't work, since its not persistent. 

     



  • 2.  Re: Update DevTest Portal URL

    Posted 03-01-2017 04:19 PM

    Refer to this documentation link:

    Activate the Registries - DevTest Solutions - 10.0 - CA Technologies Documentation 

     

    If you use a remote registry for DevTest Portal, set the lisa.registryName property in the local.properties file to the URL of the registry.

    For example: You have two machines. Your registry is running on a machine with IP address 10.155.12.796 but you want to start DevTest Portal on a different machine. On the second machine, add lisa.registryName=tcp://10.155.12.796:2010/Registry tolocal.properties. To connect using SSL between DevTest Portal and registry, uselisa.registryName=ssl://10.155.12.796:2010/Registry instead. If you use a custom port, it would go in place of the 2010 in that URL. Machine names and domain names can be used instead of IP addresses assuming they can be resolved by the network.
    You must also set the registry.host property in phoenix.properties. If you use a custom port, registry.host.port is required as well.


  • 3.  Re: Update DevTest Portal URL

    Posted 03-01-2017 04:51 PM

    Hi Marcy, I don't think this will resolve my issue. I actually have the portal connected to the registry. The portal is working as expected. The issue I am seeing, is that this text field when browsing to port 1505, is displaying the DNS name used in the lisa.registryName parameter. This is wrong because the portal is on a different server, with a different DNS. I cleared the text box for the purposes of not displaying any private information. In the following instructions, all I see is that we are setting the registry values. I need to set the hostname of the portal. I did some research and found port 1505 is being served up by the registry docker container.

     

    On a side note, the phoenix.properties doesn't exist in the portal docker image.



  • 4.  Re: Update DevTest Portal URL

    Posted 03-01-2017 05:29 PM

    Yes, the Registry still runs on Port 1505, but you still need to update the phoenix.properties file on where the Portal.  So you will need to add this to the image where the Portal is running.



  • 5.  Re: Update DevTest Portal URL

    Posted 03-01-2017 05:51 PM

    I was able to get the portal to connect to the registry without updating the pheonix.properties file by passing in the registry name via command line, like this 

    /opt/devtest/bin/Portal -J-Dregistry.host="$REGISTRY_URL" -J-DlisaAutoConnect="tcp://$REGISTRY_URL:2010/Registry"

     

    ie Here are my DNS names

     

    svportal.mycompany.com Portal

    svregistry.mycompany.com Registry

     

     

    Where I set the lisa.registryName and in the example above REGISTRY_URL, I use the DNS svregistry.mycompany.com.

     

    When I browse to svregistry.mycompany.com:1505, the text field URL is displaying svregistry.mycompany.com:1507. This is wrong because the portal doesnt exist on the registry server. It should display: svportal.mycompany.com:1507. In the provided solution, I do not see anywhere to set this string. There should be a property called lisa.portalname or phoenix.hostname but I cannot identify a property that matches this. 

     

    It's not a major issue, as I can manually go to svportal.mycompany.com:1507 but it is a problem because when someone clicks check availability or go link, it fails. 

     

    Here are the  screenshots. ondemand41.sv_registry.service.pasdev.consul:2010 is the registry server. But the URL field has the same value. Instead I need it to be ondemand41.sv_portalservice.pasdev.consul

     



  • 6.  Re: Update DevTest Portal URL

    Posted 03-01-2017 05:59 PM

    I will do some further testing on this.



  • 7.  Re: Update DevTest Portal URL

    Posted 03-01-2017 06:03 PM

    Great thanks so much Marcy



  • 8.  Re: Update DevTest Portal URL
    Best Answer

    Posted 03-03-2017 09:33 AM

    I found a workaround for this. I was putting the IP in directly in registry name. Instead I bounded the components to our NetScaler VPX (LoadBalancer). Using a VIP, when requests come in to 1507, I forwarded to the portal. Since, in that text field it inserts the port, this works.