Service Virtualization

Expand all | Collapse all

Default ACL users not available after moving Registry to external database

  • 1.  Default ACL users not available after moving Registry to external database

    Posted 02-12-2016 08:19 AM

    Default ACL users not available after moving Registry to external database. Is this something everyone has faced ? I am not sure how to login now

    I am using DevTest 9.1 and MySql database



  • 2.  Re: Default ACL users not available after moving Registry to external database

    Broadcom Employee
    Posted 02-12-2016 08:25 AM


  • 3.  Re: Default ACL users not available after moving Registry to external database

    Posted 02-12-2016 08:28 AM

    Yes Koustubh, I have followed all the steps mentioned in the link pasted by you



  • 4.  Re: Default ACL users not available after moving Registry to external database

    Broadcom Employee
    Posted 02-12-2016 08:32 AM

    Good. What version of MySql?


    - Can you check the registry log file for error messages during login?


    - can you look at the acl_users table and confirm that you can see the default users?


    - if all's good above, backup registry.log, delete the file and restart registry service and then re-login and look at the log file



  • 5.  Re: Default ACL users not available after moving Registry to external database

    Posted 02-12-2016 08:42 AM

    Koustubh, thanks for the quick response. I have deleted all the tables and restarted the registry. That has fixed the issue.

     

    Thanks



  • 6.  Re: Default ACL users not available after moving Registry to external database

    Broadcom Employee
    Posted 02-12-2016 10:08 AM

    Great! Enjoy!