Service Virtualization

 View Only
  • 1.  Learning mode is not creating new VSI

    Posted Apr 01, 2016 04:00 PM

    I'm using DevTest 8.4 version. I've deployed a service which is created from recording mode. I changed my service behavior to




    I did few transaction, I got response from the live services, then I can't see the VSI icon near service name in VSE console. I tried to download the MAR still no luck. How can this new VSI can be taken so that I can merge it.




    Is something I'm missing here?

  • 2.  Re: Learning mode is not creating new VSI
    Best Answer

    Posted Apr 01, 2016 04:55 PM

    Found the way to get updated learned VSI.

    1.Right click on the learning phase service and select "View session or Tracking information."

    2. Click on Refresh button on the page.

    3. We can see new stateless in the list. Selecting that and clicking on “Update” button creating new VSI and triggering download.


    We can merge that VSI with old one and redeploy the service.