Service Virtualization

Expand all | Collapse all

Running Test Case in Portal does not present Output log message

Jump to Best Answer
  • 1.  Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 09:54 AM

    Hi team!

     

    I'm running some test cases in DevTest Portal. After the execution, I can verify the result at "Monitoring Tests", but all "Output log message steps" doesn't presents value.

    I'd like to know how to exibit those log messages running the test in portal.

     

    Regards,

    Francis



  • 2.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 11:41 AM

    Output log message step is set to Quiet by default. If you uncheck the 'Quiet' setting in step definition, it should be visible.



  • 3.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 12:58 PM

    Hi Ching kunch03,

     

    It's already unchecked the Quiet setting.

     

    Bellow you can see a print screen for a test case with just one "output log message" step. 

     

    ScreenHunter_422 Sep. 03 13.55.jpg

     

    I'm using DevTest 8.02.

     

    Regards,

    Francis



  • 4.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 01:37 PM

    Hi Francis,

     

    Do you click the right arrow to expand the detail view? I tried on 8.0.2 and it seems ok on mine.

     

    DevTest-8.0.2



  • 5.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 01:42 PM

    Ching, kunch03

     

    I clicked but the screen doesn't expand like yours.

     

    ScreenHunter_423 Sep. 03 14.39.jpg

     

    Is there any configuration for this?

     

    Thanks,

    Francis



  • 6.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 01:48 PM

    Francis,

     

    No, there is nothing you need to configure. Can you share the content in your Output log message step? Do you have any special character or string? Which browser do you use?



  • 7.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 02:02 PM

    Ching, kunch03

     

    My step just have the text: BLA BLA BLA, as you can see in the print bellow.

     

    ScreenHunter_424 Sep. 03 14.58.jpg

     

    I tryed to open in Chrome, Firefox. The same problem occur in both.

     

    Thanks,

    Francis



  • 8.  Re: Running Test Case in Portal does not present Output log message
    Best Answer

     
    Posted 09-03-2015 03:15 PM

    Francis, I think this is controlled via staging doc.

     

    Please follow the steps and see if it helps.

    1. Create a staging doc in workstation.

    2. In the new staging doc, click second tab 'Reports' in the bottom.

    3. Check parameter 'Record All Events' and 'Record Properties Set/Referenced'

    4. Make sure the staging doc is managed under Portal (like copy/paste action)

    5. Execute the test via 'Run with options' and pick the newly created staging doc




  • 9.  Re: Running Test Case in Portal does not present Output log message

     
    Posted 09-03-2015 05:22 PM

    Hi Ching, kunch03

     

    It worked perfect! Thanks a lot!

     

    Regards,

    Francis