Test Data Manager

Expand all | Collapse all

Getting below error while using inplace masking in mainframe

Jump to Best Answer
  • 1.  Getting below error while using inplace masking in mainframe

    Posted 05-17-2018 05:03 AM

    Hi Team,

    We need your help to resolve below encountered while masking data in mainframe for Db2.

     

     

    Error msg:


    ******************************** Top of Data ******************************
    Program name GTXMSK
    Program version 5.0.8
    Program date 2014-10-13
    <END-OF-STATEMENT>:NOT EXISTS XMLEXISTS ARRAY_EXISTS + - CASE CURRENT_
    ******************************* Bottom of Data ***************************

     

     

    Thanks

    Rajeev Kumar



  • 2.  Re: Getting below error while using inplace masking in mainframe

    Broadcom Employee
    Posted 05-18-2018 04:43 PM

    Hi Rajeev,

     

    Have you taken a look at the Best Practices guide yet?

    Here's the link for your quick reference.:

    https://communities.ca.com/docs/DOC-231181387-mainframe-in-flight-masking-best-practice-guide



  • 3.  Re: Getting below error while using inplace masking in mainframe
    Best Answer

    Posted 05-22-2018 09:17 AM

    Rajeev,

     

    You may also want to update the MF components. The version you have is quite old. The latest version is 5.4.14 released in March 2018.

     

    Regards,

    Sean



  • 4.  Re: Getting below error while using inplace masking in mainframe

    Broadcom Employee
    Posted 05-28-2018 03:40 AM

    Hello Rajeev,

     

    please can you indicate whether you were able to overcome the issue with the information provided by Ryan and Sean or do you need any additional help?

     

    Thanks,

     

    Ruth



  • 5.  Re: Getting below error while using inplace masking in mainframe

    Posted 05-31-2018 10:40 AM

    The issue is resolved after having updated installation  of CA mainframe package for masking.

     

    Thanks

    Rajeev Kumar.