Test Data Manager

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Tech Tip: ORA-12154: TNS could not resolve the connect identifier specified

  • 1.  Tech Tip: ORA-12154: TNS could not resolve the connect identifier specified

    Posted Nov 08, 2017 11:17 PM

    This document can also be viewed in our TDM knowledge base here: https://support.ca.com/us/knowledge-base-articles.TEC1391224.html 

    Issue:

    When trying to connect to the repository, I am receiving the following error:

     

    FATAL CA Test Data Manager- Datamaker logon error.
    Cannot connect using the supplied values.
    ORA-12154: TNS could not resolve the connect identifier specified. 

    Environment:
    CA Test Data Manager (TDM)- Datamaker, Portal, or Test Data on Demand (TDoD)
    Cause:

    This error message can occur when installing Datamaker or connecting to the repository in Datamaker, Portal, or TDoD. The most common cause of this error message is that the tnsnames.ora file in not in the correct location for TDM to use it. Also make sure that the version of Datamaker installed on the system is compatible with the repository version.

    Resolution:

    To resolve this issue, please copy your tnsnames.ora file from <ORACLE_HOME>\Network\Admin into the following locations:

    • C:\Program Files (x86)\Grid-Tools\GTDatamaker
    • C:\Grid-Tools\TDoD\TDoD_ConfigEditor\libraries


    You may also need to check your rep.xml file has the same updated information as the tnsnames.ora file. This document outlines how to find existing rep.xml files and create a new one if needed: https://support.ca.com/us/knowledge-base-articles.TEC1656693.html 

    Additional Information:

    If you are still experiencing any issues, please open a support case by going to https://support.ca.com/us.html