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Tech Tip: TDM Portal Publish Error: Call to ConnectionManagerService failed

  • 1.  Tech Tip: TDM Portal Publish Error: Call to ConnectionManagerService failed

    Posted Nov 08, 2017 11:13 PM

    This document can also be viewed in our TDM knowledge base here: https://support.ca.com/us/knowledge-base-articles.TEC1243815.html 

    Issue:

    When trying to do a publish with the TDM Portal, I am receiving the following error message:
    Publish failed for job xxxx, Call to ConnectionManagerService failed: : HttpClientErrorException: 404 Not Found

     

    The same publish through Datamaker works and I have verified that the connection to the Portal is working.

    Jobs are successful when I submit them as an administrator.

    Environment:
    CA Test Data Manager (TDM)- Web Portal
    Cause:

    In order to identify the root cause, you will need to enable debugging in the Portal, recreate the issue, and then analyze the logs (specifically TDMConnectionProfileManager.log).
    Here are directions on how to enable debugging: https://support.ca.com/us/knowledge-base-articles.TEC1254734.html 

     

    There are a few possible causes for this error message:

    • The Portal may not be able to find the connection profile referenced in the publish.

    • The user is not linked to the connection profile being used in the publish.

    • If you are using Oracle, you might not be using an EZ_Connect String

    • You may not be using a DSN-Less connection profile. 

    • The connection profile may be configured improperly. 

    • The connection profile being used in TDM Portal has the same database and schema as a profile in Datamaker, despite having a different name. If the tables are registered through one profile name in Datamaker, but the Portal name is different, this could cause an issue.

     

    If you are using TDM 4.0 and lower, you may not receive as informative error message. This was fixed in TDM 4.1.

    Resolution:

    Here are several possible resolutions based on the possible causes listed above:

    User not linked to connection profile:
    - Make sure the user is added to a user group from the "Configuration" -> "User groups" menu in the portal. 
    1. Click on the relevant user group and then click "Users" and "Add User". 
    2. Select the user name you wish to add to the group and save the settings. 
    3. From the "Configuration" -> "Connection Profiles" menu, click on the relevant connection profile(s) and select the user groups used in (1) above, that you wish to link the profile with. 
    4. Click "Add". When all required profiles have been added, click "Done".
    5. Retest the publish.

     

    Connection profile has same DB and schema as Datamaker:
    1. Unregister the table in Datamaker.
    2. Re-register the tables using the same profile name that is used TDM portal. 
    3. Retest the publish.

     

     

    Unable to find connection profile:
    1. Update the default publish through Datamaker.
    2. Verify the profile is visible in the Portal.
    3. Retest the publish.


    Using Oracle:

    1. Update the profile details so that the Oracle DB name is in the EZ_Connect format. 
    - For TDM versions 3.8 and above, the Portal takes the new format of Java based connection strings in EZ_Connect format.
    2. Retest the publish.

     

     

    More specific error message:
    In TDM 4.1+ we have fixed the 404 error message with a more instructive message:
    Connection profile was not found or not shared or is not compatible. Oracle profiles must use an EZConnect String and other profiles must be DSN-Less.

    Additional Information:

    If you experience any further issues, please open a support case by going to https://support.ca.com/us.html