Harvest

Expand all | Collapse all

Can't configure harvest with Oracle 12C

Jump to Best Answer
  • 1.  Can't configure harvest with Oracle 12C

    Posted 07-16-2018 04:03 PM

    Hi everyone,

     

    I configured the conexion between harvest and Oracle 12, but when i tried to test the conexion ir fails.

     

    Regards,

    Thanks.



  • 2.  Re: Can't configure harvest with Oracle 12C
    Best Answer

    Broadcom Employee
    Posted 07-16-2018 04:26 PM

    There are a couple of possible causes for this problem:

    1. Your tnsnames.ora file is providing the wrong hostname and port number, and so you are connecting to the wrong Oracle instance

    2. You have provided a valid Oracle login id and password, but not the login id for the schema owner to the Harvest database.

     

    During this "Test Repository" step, Harvest will login to the Oracle database it finds at the hostname and port number in tnsnames.ora, and under the schema owner's userid it will look for a table named "HARTABLEINFO".  If it doesn't find that table either it's got the wrong schema owner, or it's got the wrong database.

     

    You can verify the settings with SQL*Plus.  Try this command from a command prompt:

     

    sqlplus userid@servicename/password

    Where:

    - userid = the harvest database schema owner userid

    - servicename = the tns service name from your tnsnames.ora file

    -password = the harvest database schema owner password

     

    After logging in, execute this statement to verify the database is there:

     

    select * from hartableinfo;

     

    Let me know if this helps. 



  • 3.  Re: Can't configure harvest with Oracle 12C

    Posted 07-16-2018 04:39 PM

    Hi Melinda,

     

    I can do that select. 

    when I configured the CO (configure odbc DSN) it says "Connection test succeeded" but when i try to test the connection it shows the error ORA-00942.

    and when i tried to start the service it can't start and show this message in the logs

     



  • 4.  Re: Can't configure harvest with Oracle 12C

    Posted 07-16-2018 05:44 PM

    I'm reading that maybe is an error of permissions, do you know what permissions the user of harvest DB are required??

     

    Regards.

    Thanks



  • 5.  Re: Can't configure harvest with Oracle 12C

    Broadcom Employee
    Posted 07-18-2018 11:46 AM

    I did a quick search of KB articles and previous cases and found a few other things you might check:

     

    https://comm.support.ca.com/kb/harvest-hdbsetup-ur-database-error/kb000032909

    You might also check to make sure enough disk space is available for your SCM database-error/kb000032909

     

    In a few previous cases, the problem was resolved by granting view access to v$session for the harvest schema owner userid

     

    Here is another KB article on this topic with a few suggestions:

    .https://comm.support.ca.com/kb/error-message-e03020003-database-error-oracleodbcoraora-00942-table-or-view-does-not-exist-is-returned-after-the-upgrade/kb000049448

    Can you check on these things to see if any of the suggestions might solve the problem?

     

    Let me know what you find out.

     

    Thanks