Release Automation

 View Only
  • 1.  nolio git clone action

    Posted Dec 06, 2018 02:26 AM
      |   view attached

    Hi Team, 

    I am not able to use Git-Clone action in my nolio process. I have supplied all the mandatory values including the git clone URL and credentials. I get the NullPointerException even though i have supplied all the values. I tried with both SSH and HTTP URLs. My current GIT version is 2.6.3 and I am manually able to clone the repository using the same URLs. My colleague tried testing this in Nolio UAT and it works fine for her. While when i supply the similar values I get the exception. Please let me know if any other details are required from my end, a log screenshot is already attached.

  • 2.  Re: nolio git clone action

    Broadcom Employee
    Posted Dec 06, 2018 03:42 AM



    Did you set [Remote Repository user name] and [Remote Repository user password]?

    If not, please set them and try again. I expect it works fine or different error.




  • 3.  Re: nolio git clone action

    Posted Dec 07, 2018 02:34 AM

    We have set it but still the error is same.

  • 4.  Re: nolio git clone action
    Best Answer

    Broadcom Employee
    Posted Dec 10, 2018 03:37 AM



    removePasswordFromReturnMessage method in the exception is used to replace actual password to ***** before writing logs. It refers to username and password from inputs.


    Does your password have special characters? If so, can you change the password using alphanumeric only temporarily and try again?


    Additionally, RA tried to execute following command according your screenshot.

    Did you try same options in command line manually although I heard you already used same URL?

    If not yet, please try the command from working folder without RA, check the result. 

    /usr/bin/git clone --progress --recursive ssh://git:<PASSWORD>




  • 5.  Re: nolio git clone action

    Broadcom Employee
    Posted Dec 25, 2018 08:52 PM



    Did my suggestion help you?

    Could you please share your attempt and result?