Release Automation

Expand all | Collapse all

TFS Checkout Action - Doesn't Work

Jump to Best Answer
  • 1.  TFS Checkout Action - Doesn't Work

    Posted 02-01-2018 10:04 AM

    I am planning to checkout code from TFS plugin. But, it's throwing below error! Can someone help me on this one?

     

    Action Parameters:

     

     

    Your help will be highly appreciated -

     

    Thanks,

    Raghavendra Guttur

    EMC Data Storage Systems

    Bangalore



  • 2.  Re: TFS Checkout Action - Doesn't Work

    Broadcom Employee
    Posted 02-01-2018 03:11 PM

    Hello Raghu,

     

    I am not all that familiar with TFS but I just did a search on google for that error. It looks like the errors is being returned by TFS and it has some prereqs before doing the checkout. This URL might help:

    tf.exe: Unable to determine the workspace – Grant Holliday's Blog 

     

    Kind regards,

    Gregg



  • 3.  Re: TFS Checkout Action - Doesn't Work
    Best Answer

    Posted 02-02-2018 06:31 AM

    Hey,

     

    as Gregg said, there are prerequisites before you can do the Get/Checkout.

     

    This is how we do it:

    1) Accept TEE Eula (needs to be done, because we're using VSTS and not an on-premise TFS instance)

    2) Create TFS Workspace

    3) Create TFS Workfolder

    4) TFS Get

     

    Forgot the steps in the post deployment:

    1) delete TFS Workspace

    2) delay 10s

    3) delete TFS Workfolder

     

    best regards

    Michael



  • 4.  Re: TFS Checkout Action - Doesn't Work

    Broadcom Employee
    Posted 02-06-2018 09:00 AM

    Hi

    Did the answers on this thread answered your question? If it did please mark it as the right answer.
    When your question is not answered or you still have additional questions please let us know.

    With Kind Regards
    Dirk



  • 5.  Re: TFS Checkout Action - Doesn't Work

    Posted 02-07-2018 03:20 AM

    Thanks Mike & Greg!

    I was using Powershell script to checkout code or to commit the code back to TFS repo.

    Issue was the account used to run the Nolio Agent service. After changing it to the specific service account used to checkout the code, all seems to be working. CA RA TFS plugin, PowerShell and Manual commands are working without any issues. Great support and thanks a ton!