Release Automation

 View Only
  • 1.  ROC and Dashboard disabled

    Posted Nov 27, 2015 02:22 AM

    My customer has CA RA 4.7. I am setting up the environment in my new laptop. I have Java 6, environment variables set. When I load the nolio-app url, I can see the three parts of ROC, AS, Dash@board. The problem is, ROC and Dashboard are disabled, I thought they are disabled on purpose, but No, only I am facing this issue. I checked in another Desktop, they were accessible.

    Under Automation Studio it shows this message 'Automation Studio requires Sun JRE™ 6.0 to be installed in order to ', though I have java 6, I am facing this weird issue. Please help me with appropriate fix.



  • 2.  Re: ROC and Dashboard disabled

    Broadcom Employee
    Posted Nov 29, 2015 08:53 PM

    It seems the problem is browser security setting issue.

     

    ROC and Dashboard requires to enable Java Script.

    Did you try to set your NAC server as trusted site in browser security settings?

     

    ASAP requires Java Development Toolkit to check Java version. You also need to associate asap.jnlp with javaws.exe under your JRE or Release Automation installation folder.

    If you use Chrome 45 or later, you may not be able to enable Java Development Toolkit because Google determined not to support Java plug-in. So, please try to use Firefox or IE.

     

    Thanks

    Yas



  • 3.  Re: ROC and Dashboard disabled

    Posted Dec 01, 2015 08:46 AM

    Hi Yas,

     

    All your suggestions are valid and I have tried. But no use, I'm attaching the screen shot of my CA RA.

     

    The red circles are the areas disabled.

    Blue one is where I can download asap.jnlp, but when I open it in notepad - please see below.

     

    <jnlp spec="6.0+" codebase="null//null/nolio-app">

     

    <property name="nolio.app.code.base" value="null//null"/>

     

    I have set NAC server as trusted site in security settings.

    I have JDK 1.8 (latest).

    I have associated asap.jnlp with javaws.exe.

    I tried in Firefox as well, no change and my default browser is IE.

     

    My guess is, somehow the Java detection is corrupted in my machine alone. or maybe something else.

     

    This is eluding me, coz I have been working on CA RA since 2013 and the versions 4.7, 5.0.1 and 5.0.2.CA RA.jpg



  • 4.  Re: ROC and Dashboard disabled

    Broadcom Employee
    Posted Dec 02, 2015 04:49 AM

    Hi,

     

    Unfortunately, RA doesn't support JDK 1.8. Please revert to JDK/JRE 1.6 you used before.

    I mistook on my previous comment. We need to enable plug-in - not [Java Development Toolkit] but [Java Deployment Toolkit].

     

    I tried to disable JavaScript on my firefox, and then [Launch] button was disabled. So, your problem is related to JavaScript configuration, I think.

    My step:

    1. Input [about:config] to address bar on Firefox.

    2. Set [false] to [javascript.enabled].

    3. Restart Firefox and access RA launcher.

    And then, there is no responses when I click [Launch] button.

    Reverted [true] to javascript.enabled, and then ROC could be launched properly.

     

    Please check javascript configuration in your browser.

     

    Additionally, your security applications may block your browser behavior. If possible, please stop security applications like antivirus and try again.

     

    Thanks

    Yas



  • 5.  Re: ROC and Dashboard disabled

    Broadcom Employee
    Posted Dec 02, 2015 05:56 AM

    Please do note that 4.7.1 is considered unsupported - you can see the letters on the support.ca.com homepage for CA Release Automation.

     

    I'm not sure what to say regarding the ROC piece. Maybe try different browsers - both 32 and 64 bit versions. Generally I have personally had best results with chrome. I do recall seeing something like that once and thought it had to do with the browser and possibly the architecture matching the architecture of java that was installed.

     

    For launching asap, I have seen that and do not know why it happens. But know that you can change those two exact entries that you found (in the .jnlp) to reflect:

    <jnlp spec="6.0+" codebase="http://<yourRAServername:port>/nolio-app">

     

    <property name="nolio.app.code.base" value="http://<yourRAServername<and maybe :port>>"/>