Release Automation

  • 1.  Jenkins PlugIn : Artifact not uploaded to repository

    Posted 12-18-2014 03:19 AM

    When using the Jenkins plugIn, customer check the box to upload their artifact in our repository.

    But after launch of build, and RA post process, the created deployment plan doesn’t work with error below:

    "The following errors occurred during Artifact Package distribution:

    Failed to download artifact [Artifact [ Composant Tomcat.Composant'ver. 2014-12-17_15-01-29']] to retrieval agent [ottawa.swisslife.lan]. Local agent error is [Error storing the artifact - files\ART31024000\31024000\30976000\PXI16_LIV (Accès refusé)]

     

    This error is visible when execution server try to deliver artifact to agents."

     

    The artifact is created in Nolio, but, when looking at artifact details, it seems it hasn’t been uploaded to our repository at all.

    When looking at server details, we see this folder is a temporary agent folder, where the artifact is stored and present.

     

    If we save again the artifact on ROC, then the upload works, but the deployment still show same error.

     

     

    What happens ? How can we ensure the full process works automatically ?



  • 2.  Re: Jenkins PlugIn : Artifact not uploaded to repository

    Posted 01-08-2015 03:46 AM

    Hi, please open a case with support.

    Thank you,

    Yael



  • 3.  Re: Jenkins PlugIn : Artifact not uploaded to repository
    Best Answer

    Posted 01-08-2015 09:01 AM

    The case was opened to support last year.

    After investigation, they confirmed that RA don't support upload of a directory as an artifact. This was the source of this error.

    Solution was to zip the folder, then upload the zip as the artifact.

     

    Confusion on this was due to the facts that:

    - the error message isn't explicit at all

    - the upload of a directory as an artifact worked well from the RA web portal