Clarity

Expand all | Collapse all

PPM upgrade fail from 14.2 to 15.3

Jump to Best Answer
  • 1.  PPM upgrade fail from 14.2 to 15.3

    Posted 01-26-2019 07:55 AM
      |   view attached

    Hello SumanPramanik,

     

    I have failed while upgrading from 14.2 to 15.3. Seems like the problem is about REGISTER_INVS_FOR_CAPEX_JOB but I am not sure. I shared a part of the log and  I attached install.log. 

     

    Thank you

     

     

    /25/19 7:06 PM (ExecTask) Applying REGISTER_INVS_FOR_CAPEX_JOB.xml
    1/25/19 7:06 PM (ExecTask) C:\app\cappm\.setup\scripts\db.xml:2302: The following error occurred while executing this line:Error Applying XOG: Failure occurred while applying REGISTER_INVS_FOR_CAPEX_JOB.xml
    1/25/19 7:06 PM (ExecTask)
    1/25/19 7:06 PM (ExecTask) Check C:\app\cappm/logs/xog-seeddata/out/revmgr\REGISTER_INVS_FOR_CAPEX_JOB_out.xml for errors
    1/25/19 7:06 PM (ExecTask) C:\app\cappm\.setup\scripts\db.xml:2518: The following error occurred while executing this line:
    1/25/19 7:06 PM (ExecTask) C:\app\cappm\.setup\scripts\db.macros.xml:93: Java returned: 2
    1/25/19 7:06 PM (ExecTask) at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:568)
    1/25/19 7:06 PM (ExecTask) at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:443)
    1/25/19 7:06 PM (ExecTask) at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
    1/25/19 7:06 PM (ExecTask) at com.niku.tools.taskdefs.xpath.Iter.executeTarget(Iter.java:294)

     

     

    • This is the related xml file. 

     

    <?xml version="1.0" encoding="UTF-8"?>
    <XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">
    <Object type="contentPack"/>
    <Status elapsedTime="0.047 seconds" state="FAILURE"/>
    <Statistics failureRecords="0" insertedRecords="0" totalNumberOfRecords="0" updatedRecords="0"/>
    <ErrorInformation>
    <Severity>FATAL</Severity>
    <Description>User : unknown does not have necessary rights to perform this operation </Description>
    <Exception>contentPack XOG Failed.</Exception>
    </ErrorInformation>
    </XOGOutput>

    Attachment(s)

    zip
    install.log.zip   37K 1 version


  • 2.  Re: PPM upgrade fail from 14.2 to 15.3
    Best Answer

    Posted 01-28-2019 02:39 AM

    Hi Ferhat,

     

    The error in the upgrade is due to the rights provided to the user admin. Please roll back and assign all the global rights to admin and redo the upgrade.


    Regards

    Suman Pramanik 



  • 3.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-07-2019 05:04 AM

    Thank you Suman,

     

    I managed to upgrade from 14.2 to 15.5. However, I have a new error while upgrading from 15.5 to 15.5.1. I could not find any clue. I got the error at the beginning. Some part of it is below. 

     

    2/07/19 12:09 ÖS (Target) Target "_perform_check" finished.
    2/07/19 12:09 ÖS (Target) Target "perform_post_install_check" finished.
    2/07/19 12:09 ÖS (Target) Target "checkinstall" finished.
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo) -------------------------------------------------------------
    2/07/19 12:09 ÖS (Echo) The Post check for install/upgrade results contain warnings.
    2/07/19 12:09 ÖS (Echo) Please see the checkinstall/check-logs/postcheck-results.html and
    2/07/19 12:09 ÖS (Echo) checkinstall.log files for information.
    2/07/19 12:09 ÖS (Echo) -------------------------------------------------------------
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Target) Target "_postcheck" finished.
    2/07/19 12:09 ÖS (Target) Target "_postprocess-upgrade" finished.
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo) ----------------------------------------------------------------
    2/07/19 12:09 ÖS (Echo) The Upgrade failed with an error. Please review the install.log.
    2/07/19 12:09 ÖS (Echo) ----------------------------------------------------------------
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (Echo)
    2/07/19 12:09 ÖS (UnknownElement) Task "fail" finished with error.
    C:\Beat\staging\15.5.1\install.xml:501: No message
    at org.apache.tools.ant.taskdefs.Exit.execute(Exit.java:164)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
    at jdk.internal.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)



  • 4.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-07-2019 05:10 AM

    Great to hear Ferhat. Can you share the install.log please



  • 5.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-07-2019 05:18 AM

    I shared install.log as install_15_5_1.rar below. Thank you



  • 6.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-07-2019 05:21 AM

    Hi Ferhat,

     

    Looks like you did not set up DWH and hence the error 

     

    C:\Beat\staging\15.5.1\checkinstall\scripts\check-db-dwh-export-permissions.xml:31: java.sql.SQLNonTransientConnectionException: [CA Clarity][Oracle JDBC Driver]Error establishing socket to host and port: 0:0:0:0:0:0:0:1:1521. Reason: Connection refused: connect
    at org.apache.tools.ant.taskdefs.JDBCTask.getConnection(JDBCTask.java:381)

     

    You need to set up DWH and try again.


    Reards
    Suman Pramanik 



  • 7.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-08-2019 03:36 AM

    Hi Suman,

     

    I've never set up DWH  for any other upgrades and they were all fine. I found something else shared the log below. I tryed to delete "wrapper.jar" manually but could not do it. Then I realized that there is a ppm service running although I removed them all from command prompt. When I stoped that running service I managed to delete it and it looks fine so far. Thank you.

     

    "C:\Beat\staging\15.5.1\install-packages\15.5.1\install.xml:235: Unable to delete file C:\app\cappm\bin\wrapper.jar "



  • 8.  Re: PPM upgrade fail from 14.2 to 15.3

    Posted 02-08-2019 09:26 AM

    DWH is mandatory for your out of box reports to be working. Glad you saw the other error and while installation all your services should be ideally down