Clarity

Expand all | Collapse all

Mismatch of Cost Plan data between UI and Slice table

  • 1.  Mismatch of Cost Plan data between UI and Slice table

    Posted 05-06-2018 01:58 AM

    We are using Clarity version 15.4. We see there are differences in values of Cost in the slice table ODF_SSL_CST_DTL_COST and Clarity Cost plan details page. In the slice table we are getting value of 14,300 and in Clarity it is 0. Anyone have idea about this issue? Time slicing job also ran.

     

     

    Thanks,

    Justine



  • 2.  Re: Mismatch of Cost Plan data between UI and Slice table

    Broadcom Employee
    Posted 05-07-2018 02:57 AM

    Hi Justine,

    Can you please run the below query and see if you are getting the records for the above project in the results.

    If you are getting them, it means the slices are not up to date. 

     

    Please make sure the Time Slice job is running fine. 

    If they are running fine and is still not updating, try updating the cost in the tsv and then run the time slice as it can trigger any "missed" out records.. 

     

    select systimestamp as current_time , det.id, det.total_cost, det.odf_ss_cost, slc.start_date, cast(slc.created_date as TIMESTAMP), slc.slice
    from fin_cost_plan_details det left join odf_ssl_cst_dtl_cost slc on det.id = slc.prj_object_id
    where last_updated_date > sysdate - 0.1

     

    Thanks,

    Jerin



  • 3.  Re: Mismatch of Cost Plan data between UI and Slice table

    Posted 05-07-2018 04:19 AM

    Thanks for your reply. Time slicing are working fine and for all other projects the values we are getting from slice table are correct and up to date.



  • 4.  Re: Mismatch of Cost Plan data between UI and Slice table

    Posted 05-07-2018 08:14 AM

    Is it the problem with all the slice values for this specific project? Is the CREATED_DATE in ODF_SSL_CST_DTL_COST matching with the Plan updated date?



  • 5.  Re: Mismatch of Cost Plan data between UI and Slice table

    Posted 05-07-2018 09:55 AM

    The problem is for the slice value of only one month alone.



  • 6.  Re: Mismatch of Cost Plan data between UI and Slice table

    Posted 05-07-2018 10:19 AM

    Can you try to update with value other than 0 and observe the behavior?



  • 7.  Re: Mismatch of Cost Plan data between UI and Slice table

    Posted 05-07-2018 10:24 AM

    I tried that way by giving another value instead of 0. In that case it worked correctly.



  • 8.  Re: Mismatch of Cost Plan data between UI and Slice table

    Broadcom Employee
    Posted 05-07-2018 07:30 PM

    Hi Justine,

    The blob might not have got updated due to an issue with the Time Slicing job which ran for that instance. 

    Soft reslice (which you did by updating the TSV) is the quick way to fix this issue. 

    if your issue is resolved, please mark the thread as answered. 

     

    Thanks,

    Jerin