Clarity PPM1

Expand all | Collapse all

why some attributes are read-only and some are not by default?

  • 1.  why some attributes are read-only and some are not by default?

    Posted 10-13-2017 02:03 PM

    In the application object, I have few attributes : lifecycle (data type: lookup string), decommission ( data type: boolean ) when I list these fields in the application list I am able to change the value of the decommission field by clicking on the field in the list. I wonder why I can't change the values for the lifecycle field? (even though the read only setting is not checked) What is the rule for that? is it dependent on the data type? 



  • 2.  Re: why some attributes are read-only and some are not by default?

    Posted 10-14-2017 04:45 AM

    Just wondering again...

    Those fields sound like custom fields as I do not see them in the Sandbox.

    There is an Allow editing box in the List View field properties.

    Do you have that checked or unchecked?



  • 3.  Re: why some attributes are read-only and some are not by default?

    Posted 10-16-2017 10:52 AM

    Hi urmas,

    Correct these attributes are custom fields. Both of them 'Allow Editing' is not checked. One you can change it (decommission) but the other (lifecycle) you can't. It's weird, I thought someone might have an answer. 



  • 4.  Re: why some attributes are read-only and some are not by default?

    Posted 10-16-2017 10:56 AM

    There might be something about the (custom) lookup you presumably have attached to the (custom) attribute that does not work in a list-view - for example if it is a parameterised lookup perhaps?



  • 5.  Re: why some attributes are read-only and some are not by default?

    Posted 10-16-2017 12:01 PM

    nothing special about the lookup. Regular static lookup no parameters.



  • 6.  Re: why some attributes are read-only and some are not by default?

    Posted 10-17-2017 10:37 AM

    1. Flush cache.

    2. If still not working, restore default in your portlet (just for your user), ensure it' still marked as "allow editing".

    3. Ensure field is not locked by a process or scheduler.

     

    Does it solve issue?