View Only
  • 1.  Can't login into PPM

    Posted Dec 29, 2017 08:24 AM



    I'm new to PPM and I think I made a serious mistake. I was trying to modify the timezone for all the users imported via LDAP (on a fresh installation of 15.3) and I run an Update statement directly in Oracle:


    UPDATE cmn_sec_users SET timezone = 'Europe/Bucharest';


    After that I restarted bg and app, but bg was hanging so I restarted server. After restart bg did not appear in CSA and could not be added, so I ran


    service remove bg

    service add bg


    After the services started I could no longer login into PPM. After I enter the username and password, the page starts loading and it just stays like that.

    I don't see errors in the logs..


    How can I fix this?


    Thank you!

  • 2.  Re: Can't login into PPM

    Broadcom Employee
    Posted Dec 29, 2017 08:32 AM

    I dont think its because of the update but again doing an update directly at database is never a good practice. Try the below steps


    1. Stop all the services

    2. Start CSA and Beacon

    3. Login to CSA and go under database tab to see if its showing available

    4. Then add app and bg and start.

    5. Also look into admin, nsa and app-ca logs 

  • 3.  Re: Can't login into PPM

    Posted Dec 29, 2017 09:40 AM

    Hello, Suman!


    Thanks for your reply!


    I followed your steps, but it didn't work and didn't find anything in the logs.


    I have managed to recreate the issue on a test server. There were only the default users and another test user introduced manually. After I ran

    UPDATE cmn_sec_users SET timezone = 'Europe/Bucharest';

    I could no longer login with admin user.

    I restarted server because the services could no longer be stopped.

    I set every user's timezone to its original value  directly in Oracle and then I could login again.


    I tried to do the same thing on the original server, but it doesn't work. I'm not sure I set the timezones correctly for each user.

    Is the default setting for LDAP imported users America/Chicago?


    Thank you!

  • 4.  Re: Can't login into PPM
    Best Answer

    Posted Dec 29, 2017 10:10 AM

    Are you COMMITing your direct updates made in the database?


    If you do an update on CMN_SEC_USERS and leave it uncommitted, then when you try to log into the application, it also tries to update CMN_SEC_USERS (with the last logged in date) - its conceivable that Oracle is making that second update wait until the first (direct update) is committed.


    (GUESSing obviously)

  • 5.  Re: Can't login into PPM

    Posted Jan 03, 2018 08:09 AM

    David, you're the MAN!

    Thanks a lot!

    You were right, that was the problem. 

  • 6.  Re: Can't login into PPM

    Posted Jan 03, 2018 08:11 AM

    Ahh good. You will not find me admitting to making a similar "mistake" myself in the past, oh no, definitely not me, never happened, nothing to see here, please move along...