Clarity

  • 1.  Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-09-2017 03:43 AM

    Team,

     

    We have upgraded the clarity to 14.4 version in one of our lower environment. Our Jaspersoft was already upgraded to 6.2.1, when we were in 14.3. and jaspersoft was working fine.

     

    Now when we upgraded to 14.4, OOTB reports are not working, but custom reports are running fine. (Keystore recreated after upgrade and restarted the JS tomcat, cleared the temp and work folder of the JS tomcat also).

     

    When we open OOTB report, in the screen we are getting the below error. 

     

    Error Message

    org.springframework.security.access.AccessDeniedException: Access is denied

     

    Could anyone please help me!

     

    Thanks,

    Agin



  • 2.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Broadcom Employee
    Posted 08-09-2017 03:46 AM

    Hi Agin,


    The error looks like with the permissions you had at the folder level, can you please let me know is this happening for one user or all and what are the Addance Reporting rights granted for them.


    Regards

    Suman Pramanik



  • 3.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-09-2017 11:41 AM

    Suman,

     

    User have full admin access in jaspersoft.

     

    Thanks,

    Agin



  • 4.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Broadcom Employee
    Posted 08-10-2017 02:21 AM

    Hi Agin,

     

    It looks like some folder level permission issue, can you take a back up of exsiting content, and reimport out of box and see if you are able to run the reports

     

    Regards

    Suman Pramanik



  • 5.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-10-2017 06:23 AM

    Hi Suman,

    Hope you are asking for reimporting the jaspersoft content. correct me, if am wrong.

     

    Thanks,

    Agin



  • 6.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Broadcom Employee
    Posted 08-10-2017 06:40 AM

    Yes to eliminate if you had made any changes to the folder permissions



  • 7.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-10-2017 09:02 AM

    Thanks Suman.

     

    I tried, but it not works  still same error



  • 8.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Broadcom Employee
    Posted 08-10-2017 09:04 AM

    Lets raise a support case and we need to look into details



  • 9.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-10-2017 09:13 AM

    Taking this in different direction, don't know if it will solve your issue. 

     

    We went from 14.2 to 15.2, have JS 6.2.1 running, out of the box reports working fine.  And overall performance of 15.2 is much faster, with 95% of our page hits, globally, under 2 seconds (was 4 seconds, before).

     

    Even if you have the same issue in 15.2 that you have now, I suggest that you might be better off fixing the issue in 15.2 rather than 14.4.  15.3 is due, soon.  Make the move for the performance improvements.



  • 10.  Re: Jaspersoft OOTB reports are not working after upgrade to 14.4

    Posted 08-10-2017 10:36 AM

    Can you check the permission of public and organization folders of jaspersoft repository?