Clarity

Expand all | Collapse all

Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

Jump to Best Answer
  • 1.  Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 05-15-2017 02:53 AM

    Hello,

     

    I am facing this issue 

    check-sqlserver-collation.xmlERRORDatabase collation level must be set to SQL_Latin1_General_CP1_CI_AS to avoid unexpected failures during/after the upgrade.

    when I ran the precheckinstall.bat from 14.3 to 15.2 and all my 3 database collations (niku, ppm_dwh and ppm_jaspersoft) are set to SQL_Latin1_General_CP1_CI_AS.

     

    Any suggestion to resolve this issue will be appreciated.

     

    Karim



  • 2.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 05-15-2017 09:48 AM

    Hi Karim,
    I'm facing exactly the same problem. Do you have already a workaround for this issue?
    Arthur



  • 3.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 05-17-2017 04:30 AM

    Hi Arthur,

     

    Can you try what Nika suggests me to do on her answer below.

     

    Karim



  • 4.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat
    Best Answer

    Posted 05-16-2017 04:45 PM

    Hi Karim,

     

     

    The checkinstall script will ensure you are using SQL_Latin1_General_CP1_CI_AS before continuing. This is important to guarantee your data integrity during upgrade.

     

    To ensure you are having the setting right, please check with SQL query:

     

    SELECT serverproperty('collation') as collation

     

    This will show the server collation. If you have it different from SQL_Latin1_General_CP1_CI_AS, you will have to change the server as we do not support mixed collations.

     

    I hope this helps -Nika



  • 5.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 05-17-2017 04:29 AM

    Hi Nika,

     

    I have checked my server collation and it does not have the good one SQL_Latin1_General_CP1_CI_AS.

    I will change that and let you know if it resolve the error collation. Thank you again for your help.

     

    Regards,

    Karim



  • 6.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 10-24-2017 08:25 PM

    I get exactly the same error in the precheck install run while upgrading to version 15.3.

     

    I ran the query:

     

    select  serverproperty('collation') as collation;

     

    At the Clarity Database level, we have collation :SQL_Latin1_General_CP1_CI_AS

    At the master database  level. we have Latin1_General_CI_AS.

     

     

    Changing the collation at the server level is not a simple task.

     

    Is there any alternate or clearer answer (particulary given that the lower environments on Clarity version 14 and version 13 have a same collation at the server/database level and works fine with no complain on collation)?

     

    Please advise.

     

    Thank you.

    Mayank



  • 7.  Re: Database set to SQL_Latin1_General_CP1_CI_AS error when I ran precheckinstall.bat

    Posted 10-24-2017 10:07 PM

    Mayank,

     

    As you pointed out Clarity Database and MSSQL Instance (Master Database) has different collation settings. You will have to bring both of them in sync because as per Install Guide we do not support mixed collations.

     

    Review the Imported SQL Server Database Options 

    Important! Mixed collations settings are not supported. If you change the server-level default from SQL_Latin1_General_CP1_CI_AS to another collation, create a new SQL Server instance with the correct collation SQL_Latin1_General_CP1_CI_AS before creating the CA PPM database.

     

    Regards,

    Jeet Patel