Clarity PPM1

Expand all | Collapse all

ERROR: Upgrade failed for tenant vol.2

Jump to Best Answer
  • 1.  ERROR: Upgrade failed for tenant vol.2

    Posted 02-26-2018 04:40 AM

    Hi All, 

     

    Time ago we experienced issue with upgrade (Clarity 13.3 -> 15.3) on this error: ERROR: Upgrade failed for tenant here: ERROR: Upgrade failed for tenant when installed patch 14 

     

    However this error was solved/disappeared suddenly so nobody knows what was the cause. Now it didn't happen and we are there again with this strange error on our 3rd environment. As all "known" checks has been done without any help, I'm kindly asking SumanPramanik or Nika_Hadzhikidi for valuable help and solution for the others in community. Attached is install.log which is the same as before and properties.xml file....

     

    Notes:

    App ver: Clarity 13.3.0.286

    DB ver: Oracle 12.2c

    Clarity is running fine, DB available in NSA, tablespaces are the same on DB side and in NSA . 

    Installation process will fail in 2 mins, Our DB admin said nothing is written to DB when monitored during installation... 

     

    Thanks a lot! 

    Attachment(s)

    zip
    install.log.zip   13K 1 version
    zip
    properties.xml.zip   2K 1 version


  • 2.  Re: ERROR: Upgrade failed for tenant vol.2

    Posted 02-26-2018 06:10 AM

    Hi Matej

     

    I see you are applying the patch on 13.3 and you have oracle 12 database 

     

    2/26/18 9:33 AM (ExecTask) Check admin.log or use -verbose for more information.
    2/26/18 9:33 AM (UnknownElement) Task "exec" finished with error.

     

    Is that my correct understanding. If so you need to start the patch upgrade on oracle 11 and not 12 

     

    Regards

    Suman Pramanik 



  • 3.  Re: ERROR: Upgrade failed for tenant vol.2
    Best Answer

    Posted 02-26-2018 09:34 AM

    Hi Matej

     

     

    Looks like you are trying to apply patch 14 and it fails with error:

    Caused by: /home/clarity/temp/install-packages/13.3.0.14/install.xml:902: exec returned: 1

     

    Please note that since you seem to be on 13.3.0 base release - you should be able to directly upgrade to 15.3. So since you already have Oracle 12.2 I would skip the patch 14 install and just proceed with upgrade.

     

    Hope this helps -Nika



  • 4.  Re: ERROR: Upgrade failed for tenant vol.2

    Posted 02-26-2018 10:06 AM

    Hi Both,

     

    @Suman: Yes I know, but I don't believe this is a cause as we have installed it before two times on Oracle 12g...

     

    @Nika: Hmmmm, As we wanted to follow recommended upgrade path for Clarity 13.3 (advised by CA ) so, firstly install Patch 14 (install.13.3.0.14.5.i.jar) on our Clarity v.13.3 and then continue in upgrade to Clarity 15.3 I'm quite surprised...  However this would save a lot of issues, as I didn't know this is even possible (directly from base 13.3 -> 15.3). So I've just run the installation and it's running. If it finishes successfully, this will be the best tip ever  

     

    Thanks



  • 5.  Re: ERROR: Upgrade failed for tenant vol.2

    Posted 02-27-2018 01:58 AM

    Hi All, 

     

    So I have good news, installation to Clarity 15.3 was successfull! Thanks again for Nika's tip. That's error is really no-saying to me as it can be "everything... In spite of this error was not solved, we are moved on with our upgrade.  

    On the second thread I asked for some errors I found in logs (when tried to setup DWH in System options) to not misch-match my questions. 

     

    Thanks,

    Matej



  • 6.  Re: ERROR: Upgrade failed for tenant vol.2

    Posted 02-27-2018 12:03 PM

    Thanks for letting us know Matej, glad to hear this worked for you! Please can you mark this thread as resolved? Thank you! -Nika