Clarity

Expand all | Collapse all

Jaspersoft and failover cluster not working

  • 1.  Jaspersoft and failover cluster not working

    Posted 09-19-2017 02:28 AM

    Dear all,

     

    the configuration of a failover cluster with oracle works for CA PPM itself, but not for Jaspersoft, i.e. the admin update jasperParameters throws a NullPointerException when trying to update the database connection on the Jaspersoft side:

     

    (admin) Failed to update: jasperParameters
    java.lang.NullPointerException
    at java.util.Hashtable.put(Hashtable.java:459)
    at com.niku.reporting.jasper.ClarityJasperAdmin.populateDBProperties(ClarityJasperAdmin.java:2131)
    at com.niku.reporting.jasper.ClarityJasperAdmin.updatePPMAttrsForBeanDS(ClarityJasperAdmin.java:1668)
    at com.niku.reporting.jasper.ClarityJasperAdmin.updateUserProfileAttrsForBeanDS(ClarityJasperAdmin.java:1901)
    at com.niku.reporting.jasper.ClarityJasperAdmin.updateUserProfileAttrsForBeanDS(ClarityJasperAdmin.java:1869)
    at com.ca.clarity.union.jasper.util.JasperUtils.updateJasperParameters(JasperUtils.java:97)
    at com.ca.clarity.union.jasper.util.JasperUtils.updateJasperParameters(JasperUtils.java:65)
    at com.ca.clarity.union.jasper.util.JasperUtils.updateJasperParameters(JasperUtils.java:54)
    at com.niku.nsa.service.AdminManager.doUpdate(AdminManager.java:3730)
    at com.niku.nsa.service.AdminManager.invokeAction(AdminManager.java:443)
    at com.niku.nsa.service.AdminManager.execute(AdminManager.java:196)
    at com.niku.nsa.service.Admin.main(Admin.java:77)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.werken.forehead.Forehead.run(Forehead.java:551)
    at com.werken.forehead.Forehead.main(Forehead.java:581)

     

    This is the setup of the database URLs:
    jdbc:clarity:oracle://<host>:<port>;SERVICENAME=<name>;BatchPerformanceWorkaround=true;InsensitiveResultSetBufferSize=0;ServerType=dedicated;supportLinks=true;AlternateServers=(<host>:<port>);FailoverMode=Select;ConnectionRetryCount=200;ConnectionRetryDelay=20;LoadBalancing=true

     

    Please note that CA PPM is running fine using the configured URL, so I suspect that the update jasperParameters command is not able to correctly parse the URL.

     

    Has anyone already used a failover database cluster with CA PPM and Jaspersoft?
    Any hints are highly welcome!

     

    Thanks
    Georg



  • 2.  Re: Jaspersoft and failover cluster not working

    Posted 09-20-2017 03:15 AM

    Hi George,

     

    Can you check what connection properties is defined in context.xml i.e.  \Tomcat\webapps\reportservice\META-INF\content.xml

     

    Also see this thread and it might help you Change of Jaspersoft Database Connection String of PPM_JASPERSOFT 

     

    Regards

    Suman Pramanik



  • 3.  Re: Jaspersoft and failover cluster not working

    Posted 09-20-2017 07:15 AM

    Hi Suman,

     

    thank you very much for your hint.

    In fact, we have already changed the context.xml and it works -> Jaspersoft would start up.

     

    Still, the jasperParameters command uses the properties.xml so I guess we have to change something there.

     

    Regards

    Georg



  • 4.  Re: Jaspersoft and failover cluster not working

    Posted 09-20-2017 07:50 AM

    Thanks Georg  update command reads from properties.xml