Clarity PPM

Expand all | Collapse all

15.1's Jasper CSK content in Jasper 6.2.1 against 14.3?

Jump to Best Answer
  • 1.  15.1's Jasper CSK content in Jasper 6.2.1 against 14.3?

    Posted 12-15-2016 03:44 PM

     We're on 14.3 latest fixpack & we're working to upgrade Jaspersoft to 'latest' - 6.2.1.

     

     15.1's Jasper Content has a couple reports in it not found in 14.3's Jasper content. My customers require reports such as the Project Schedule for us to migrate off of Business Objects.

     

    Is there any reason we *can't* apply 15.1's CSK content into 6.2.1 running against 14.3's datamart?

    Has anyone tried it?



  • 2.  Re: 15.1's Jasper CSK content in Jasper 6.2.1 against 14.3?
    Best Answer

    Posted 12-15-2016 04:00 PM

    Hi Robert

     

    Using reports from the newest version will be unsupported. You may try getting importing only this report but it risks to become a problem, since the report contains also dependencies such as input controls and resource bundles. Any changes could be a problem for the report or the other OOTB reports. You could create a new report with a different id and using the same jrxml but again, this could lead to issues. We have changed some of the security, so latest PPM patches have some of those fixes, but it's hard to say if everything will go well or not.

     

    I think the best recommendation would be to wait for the report to be officially included. I will check with our Product Management to see if this can be backported for you.

     

    Thanks -Nika



  • 3.  Re: 15.1's Jasper CSK content in Jasper 6.2.1 against 14.3?

    Posted 12-16-2016 09:57 AM

    Thanks Nika. This helps me help others make decisions.