Clarity

Expand all | Collapse all

Jaspersoft - Unable to run "admin update jasperParameters" command

  • 1.  Jaspersoft - Unable to run "admin update jasperParameters" command

     
    Posted 09-27-2016 10:56 AM

    Hi,

     

    Our databases (Oracle exadata cluster) have migrated to a new exadata location. We have updated all necessary information in CSA and in the Jaspersoft context.xml file.

    We can now access Jasper Server, Advanced reporting, and we can run all Datawarehouse related jobs.

    However, unable to run any report or Ad hoc view, with the following errors:

    Error when running an OOTB report

     Error for OOTB report

    Custom Ad Hoc View:

    Error for custom ad hoc view

     

    We tried to run run the admin update jasperParameters command to push the changes from the app server to the reporting server, but we are getting the following error:

    Error after the admin update command

     

    For some reason, the connection using ppmjasperadmin is refused. I verified that I am able to connect with this user via the Jasper server UI, therefore the user itself is OK and active.

     

    Does anyone have any ideas on that ?

     

    Thanks in advance !

    Sylva



  • 2.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

    Posted 09-27-2016 01:43 PM

    Hi Sylva,

     

    Can you please let us know what steps you perfomed to update the context.xml file. Also share the JDBL URL string you are using. 

     

    Try running this to see if you see any succcess admin jaspersoft syncPPMContext -userName superuser -password superuser

     

    Regards

    Suman Pramanik 



  • 3.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

     
    Posted 09-28-2016 03:59 AM

    Hi Suman,

     

    The context.xml was updated directly. Since we did not change any passwords, we did not use the $jasper_install\jasperreports-server-5.6.1-bin\buildomatic\default_master.properties file.

     

    I tried to run the command you recommended, but I am getting the same result:

     

    JDBC URL (I replaced the real data by XXXXX):

    jdbc:clarity:oracle://*********.corp:1500;ServiceName=XXXXXXXX_app.xxxx.com;BatchPerformanceWorkaround=true;InsensitiveResultSetBufferSize=0;ServerType=dedicated;supportLinks=true



  • 4.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

     
    Posted 09-29-2016 05:25 AM
      |   view attached
    This is the bg-ca.log entry while running the admin jaspersoft syncPPMContext command:

    ERROR 2016-09-29 07:58:23,521 [Thread-4] niku.security (clarity:none:none:none) UserSessionCache.get:PMD error
    com.niku.union.persistence.PersistenceException:
    SQL error code: 0
    Error message: [CA Clarity][Oracle JDBC Driver]Object has been closed.
    Executed:
     select  us.id,
                    us.token,
                    us.user_name,
                    us.pwd,
                    us.force_pwd_change,
                    us.first_name,
                    us.last_name,
                    us.email_address, us.locale,
                    us.timezone,
                    us.last_pwd_change,
                    us.bad_login_count,
                    us.is_ldap,
                    l.language_code,
                    lu.lookup_code user_status,
                    r.id resource_id,
                    r.unique_name,
                    us.home_url,
                    us.nav_state,
                    fm.id favorites_menu_id,
                    us.screen_reader_opt,
                    us.high_contrast_ui,
                    us.user_uid
            from    cmn_user_session_v us left outer join
                        cmn_menu_items fm on  fm.principal_id = us.id
                                          and fm.principal_type = ?
                                          and fm.container_type_code = ?
                                          and fm.parent_menu_id is null,
                    cmn_languages l,
                    cmn_lookups lu,
                    srm_resources r
            where   us.language_id = l.id
            and     us.user_status_id = lu.id
            and     r.user_id = us.id
            and     us.token=?
    Derived from statement:
    <?xml version="1.0" encoding="UTF-8"?>
    <statement location="securityPMD.xml" id="security.getUserSession_stmt" sortColumnPath="/data/header/sortInfo/@sortColumn" sortDirectionPath="/data/header/sortInfo/@sortDirection" slicePath="/data/header/pagination/sliceInfo/@slice" sliceSizePath="/data/header/pagination/sliceInfo/@sliceSize" inputSource="none" xmlns="http://schemas.niku.com/2002/pmd">
      <sql dbVendor="all">
        <text>
            select  us.id,
                    us.token,

     

     

    ........................................................................

    .

    .........................................................................

     

        ... 13 more
    ERROR 2016-09-29 07:58:23,524 [Thread-4] bpm.engine (clarity:none:none:none) Cannot create login session for process user: 8
    com.niku.bpm.BpmException: Cannot get SecurityIdentifier for userId: 8
        at com.niku.bpm.utilities.BpmUtils.getLoggedinSecurityIdentifier(BpmUtils.java:130)
        at com.niku.bpm.utilities.BpmUtils.getSQLTraceUserSecurityIdentifier(BpmUtils.java:502)

     

    Why is there a problem with creating a user session for process_admin ?

    I tried to run the query from the log in the DB and there are already 2 lines for process_admin. Is that normal ?

     

    The entire log attached

    Attachment(s)

    zip
    bg-ca.log.zip   22K 1 version


  • 5.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

    Posted 09-29-2016 05:38 AM

    As you moved the database you need to perform the below tech doc and then test. 

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1532398.aspx 



  • 6.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

     
    Posted 09-29-2016 09:09 AM

    Thanks Suman,

    We have also tried that. However, it did not help either.

    One surprising thing - when you use the encryption method for the password, it creates a different string every time for the SAME password (I tried a couple of times). Is that normal ?

     

    Another comment: I tested the accessibility of the Data Source BEANS in Advanced reporting - they are not accessible.

    However, all Datawarehouse jobs run fine.



  • 7.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

    Posted 09-29-2016 01:57 PM

    Jaspersoft is not a tool where you move database easily there are lot many dependencies. The encryption string will change so thats normal. if you have changed the database and perform the steps in the technical document it should work. If not you need to reinstall the Jaspersoft 



  • 8.  Re: Jaspersoft - Unable to run "admin update jasperParameters" command

     
    Posted 10-04-2016 04:55 AM

    All,

     

    Thanks for your input. Finally, we were able to resolve the issue on both environments, although I am not completely clear on what actually helped. For each environment, the steps that finally led to a solution, were different.

    Let me sum up the steps, as I hope this might help someone with a similar issue.

     

    DEV: As their databases are placed on a RAC, on exadata, the  DBA suggested to temporarily shut down an instance in each DB cluster and keep only one instance running for each of the 3 databases (Clarity DB, Data Warehouse and Jasper DB). This alone allowed me to run the "admin update jasperParameters" command and the system was back up. After that, we reactivated the full RAC and everything  works fine.

     

    TEST: The above steps did not help on TEST. Therefore, we kept trying and searching for a solution. In CSA, in the tab Database and Data Warehouse, we unchecked the box Specify URL and tried to define the connection in another way. In the end, that was not possible, so we switched the box Specify URL on again and put back the original settings. Just the fact of changing the connection details and changing them back again probably moved something and after that, everything started working.

     

    As I say, I am not sure what exactly is behind this solution, but if you are in the same situation, you might want to try that too.

     

    If anyone has any insight on what I wrote above, I would be interested.

     

    Thanks