Clarity

Expand all | Collapse all

Action Item description bugged when using "Save As" on the process

Jump to Best Answer
  • 1.  Action Item description bugged when using "Save As" on the process

    Posted 05-17-2016 06:54 AM

    Hello everyone,

     

    We recently upgraded our Clarity 13.3 to 14.3, and everything seems to work just fine. But now i'm trying to create a new version of a process to change a few things (process designed for idea approval). I put the current process on draft, and use the "save as" button, give it a new ID and new name (to reflect a new version of the process). The new process seems to copy everything (scripts, conditions, system action, etc), except the Description of the Action items, this field comes incomplete, only a a part of the original text shows.

     

    Did the max character in the Action items description decreased from 13.3 to 14.3? Can i change it?

     

    Thank you!

    Tiago



  • 2.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 09:17 AM

    Does anyone have a similar problem, or any idea what is causing this behavior?

    This also happens when i create a new process in 14.3 and use "Save As" option, so it might not be related to the upgrade.

     

    Thank you.

    Tiago



  • 3.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 09:42 AM

    Just a guess, are there any special characters in the description? If so, can you try removing them once and see if it works?



  • 4.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 09:45 AM

    Hello sridhar!

     

    There is no special characters, only regular text, and object attributes.



  • 5.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 10:26 AM

    Hi Tiago,

     

    Is there an error in the app-ca.log when you do the save as.  If so, that might give us a clue about what is happening.  If not, please open a case with support so we can do some more in depth troubleshooting with you.

     

    Sincerely yours,

     

    Jeanne Gaskill



  • 6.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 10:44 AM

    Hello Jeanne,

     

    The app-ca.log doesn't give any error, and does not write anything when i execute the "save as".

    I also noticed that when i create the new process and just go straight to "validate all and activate", after i run the new process, the "My action items" portlet all the description text is there (even though its incomplete on the action item properties). But when i access that action item details the description is incomplete (caps at 81 characters or so).

     

    The niku.cal_action_items table also shows the entire description, for that action item.



  • 7.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 10:52 AM

    Can you check the same in any other compatible browser?



  • 8.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 11:13 AM

    I tested in Google Chrome 48.0, IE 9.0.8112, and Firefox 44.0.1

     

    All have same issue.



  • 9.  Re: Action Item description bugged when using "Save As" on the process

    Posted 05-18-2016 11:27 AM

    Hi Tiago,

     

    This is a strange issue.  I think opening up a case so that we can work with you on this one is your best bet.

     

    Sincerely yours,

     

    Jeanne



  • 10.  Re: Action Item description bugged when using "Save As" on the process
    Best Answer

    Posted 06-09-2016 06:56 AM

    Here is an update on the issue. This is a small part of the response to the case that i opened for this:

     

    "What you are describing is a known issue, reported as "CLRT-80263 - Only on MS SQL Database, Action Item Description is truncated when you copy a process via 'Save As' button".

     

    As the title suggests, this is only happening on MSSQL and not on Oracle, that is your scenario. The issue has been reported against 14.2 and 14.3 (probably also present in 14.4) and current status of the defect is that Sustaining Engineering is tentatively targeting this to be fixed for Basie, our next PPM release. I do not have any information regarding any backport plans yet.

     

    I will update you as soon as I have relevant news from Sustaining Engineering regarding this internal case (CLRT-80263) and relate your case to it, I will also leave it open until then."

     

     

    Thank you all for you feedback