Clarity

Expand all | Collapse all

15.1 upgrade question

Jump to Best Answer
  • 1.  15.1 upgrade question

    Posted 10-17-2016 06:18 AM

    Hi,

     

    we have a Sandbox test environment running version 14.2 with SQL Server 2014.

    When I run the pre-install checker for 15.1, one of the errors says,

    "MSSQL Database cannot be 2014 when upgrading from pre-14.3 release. Please refer to the Product Architecture Stack (PAS) for supported database versions."

     

    Does this mean that we'd need to upgrade to version 14.3 first, and then go to 15.1?

     

    Another 15.1 question, we have other 14.2 environments (Dev, Stage and Production) which are currently SQL Server 2008 and have Windows Server 2008 R2 O/S.

     

    For 15.1, do these servers need to have Windows Server 2012 R2 O/S, as well as SQL Server 2012?



  • 2.  Re: 15.1 upgrade question

    Posted 10-17-2016 07:31 AM

    SQL 2014 is not supported for 14.2 so apparently you have unsupported configuration.

    If you follow the error message you cannot update directly (only supported configurations)

    Better probability of successful upgrade if you do 14.3 first.

    If you try without it better have backup which you can restored if the upgrade fails.

    For the second question that is what the release notes list as supported.



  • 3.  Re: 15.1 upgrade question

    Posted 10-17-2016 08:00 AM

    In addition to what urmas has said, it is always advisable when you are installing and/or upgrading CA PPM, to first review the release-specific Release Notes and Change Impact  to ensure you are all set, prepared, and compliant.

     

    - John



  • 4.  Re: 15.1 upgrade question

    Posted 10-17-2016 11:17 AM

    Thanks guys. I appreciate your advice. As this is just a sandbox environment I'm playing around with various options for now.

     

    One error I've seen when trying to go from 14.2 to 14.3 is the below:

     

    10/17/16 4:02 PM (Copy) Copying 1 file to D:\niku\Temp\14-3\install-packages\14.3.0\y\bin
    10/17/16 4:02 PM (Java) Updated properties.xml
    10/17/16 4:02 PM (Java) Updated hosts.xml
    10/17/16 4:02 PM (UnknownElement) Task "exec" finished with error.
    D:\niku\Temp\14-3\install-packages\14.3.0\install.xml:612: Execute failed: java.io.IOException: Cannot run program "y\bin\service.bat" (in directory "D:\niku\Temp\14-3\install-packages\14.3.0"): CreateProcess error=2, The system cannot find the file specified

     

    But, I check my server for this directory location - D:\niku\Temp\14-3\install-packages\14.3.0\y\bin and I do see that the service.bat file is there.

     

    Can anyone explain why this error might have been thrown?

    Thanks.



  • 5.  Re: 15.1 upgrade question

    Posted 10-17-2016 02:45 PM

    Hi Colin,

     

    This issue seems to be caused by a typo:

    java.io.IOException: Cannot run program "y\bin\service.bat"

    You most probably have entered “y” instead of the Clarity Upgrade Target directory. I’d recommend you retry again, and this should be fine.

     

    Thanks -Nika



  • 6.  Re: 15.1 upgrade question

    Posted 10-18-2016 04:23 AM

    Hi Nika,

     

    thank you. That was indeed the case. I restored my database backup and reverted to my original 14.2 config. When I run install.bat I now see that I had specified 'y' as my target installation directory instead of d:\niku\clarity as intended. So I have corrected that and populated the rest of the parameters. The installation appears to be going smoothly so far so fingers crossed.

    Thanks again!



  • 7.  Re: 15.1 upgrade question

    Posted 10-18-2016 09:57 AM

    Ok to the upgrade to 14.3 has gone ok. But for some reason the app and bg services will not start. bg and beacon started ok. I can't see anything in the admin log for reasons as to why app and nsa won't start.



  • 8.  Re: 15.1 upgrade question

    Posted 10-18-2016 10:03 AM

    Hi Colin

     

    Glad to hear the upgrade went well.

    Can you check the app-system and the nsa-system log for any error?

     

    Thanks -Nika



  • 9.  Re: 15.1 upgrade question

    Posted 10-18-2016 10:07 AM

    Hi Nika, 

    In the app and nsa system log files i see this...

     

    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option UseSplitVerifier; support was removed in 8.0
    2016/10/18 15:02:12.153 | JVM exited while loading the application.
    2016/10/18 15:02:12.471 | There were 5 failed launches in a row, each lasting less than 300 seconds. Giving up.
    2016/10/18 15:02:12.497 | There may be a configuration problem: please check the logs.
    2016/10/18 15:02:12.719 | <-- Wrapper Stopped

     

    Do we need to alos update our Wily Introscope. Currently it is at version 914.



  • 10.  Re: 15.1 upgrade question

    Posted 10-18-2016 10:24 AM

    Hi Colin

     

    Can you upload the full app-system and app-ca logs, or send them to me in PM. From this it looks like it attempted to start the services but it couldn’t. That could be related to many different configuration issues.

     

    Thank you! -Nika



  • 11.  Re: 15.1 upgrade question

    Posted 10-18-2016 10:31 AM

    Hi Nika,

     

    I just emailed you the nsa and app system log files. Thanks.



  • 12.  Re: 15.1 upgrade question
    Best Answer

    Posted 10-18-2016 11:03 AM

    Hi Colin

     

    Thank you for the logs. This does look like an issue with Wily, a variable that it doesn’t like:

     

    2016/10/18 13:28:37.771 | WrapperStartStopApp Error: Class org.apache.catalina.startup.Bootstrap found but could not be initialized: java.lang.ClassFormatError: Illegal local variable table start_pc 53 in method org.apache.catalina.startup.Bootstrap.main([Ljava/lang/String;)V

    This seems to be a known Wily issue with flag XX:-UseSplitVerifier as it’s no longer supported in Java 8.

     

    http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec600823.html

     

    Please try removing it from properties.xml and restarting the services.

     

    Hope this helps -Nika



  • 13.  Re: 15.1 upgrade question

    Posted 10-18-2016 11:12 AM

    Thanks Nika,

     

    So I would just remove the highlighted piece in the picture I have attached from the properties.xml file ?
    In the app and nsa sections?

     



  • 14.  Re: 15.1 upgrade question

    Posted 10-26-2016 10:06 AM

    Thanks Nika.

    I had to upgrade Wily to version 10 on our application server. After this, all of the Clarity services were able to initialize and start successfully. We are now testing 15-1 in our Sandbox.



  • 15.  Re: 15.1 upgrade question

    Posted 10-18-2016 11:05 AM

    WrapperStartStopApp Error: Class org.apache.catalina.startup.Bootstrap found but could not be initialized: java.lang.ClassFormatError: Illegal local variable table start_pc 53 in method org.apache.catalina.startup.Bootstrap.main([Ljava/lang/String;)V