Clarity

Expand all | Collapse all

CA 14.2 bug - Save on Subobject initiates the Project's process

  • 1.  CA 14.2 bug - Save on Subobject initiates the Project's process

    Posted 03-08-2016 04:06 AM

    Hi

    Recently we've upgraded clarity from 13.2 to 14.2.

     

    We've custom object as subobject to Project Object. By process, the attributes of Custom object is automatically filled on creation. When I click Save button on the custom object page, the process in project are all initiated.

     

    Initially I thought some of the process in Custom object has some issue. So I put on hold all the processes except the create process in Custom object.

    When I click Save, not even editing custom object, initiates all the processes under project. This results in changing lot of attributes in Project object including the status.

     

    All the approved projects are affected.

     

    This seems like a bug. Have anyone faced this issue?

     

    This happenes in Production (Version/Build- 14.2.0.237 ) and also in Dev with Generic Patch 7 (Version/Build- 14.2.0.237 07 16)

     

    Please advise ASAP

     

    Thanks

     

    Sreeram



  • 2.  Re: CA 14.2 bug - Save on Subobject initiates the Project's process

    Posted 03-08-2016 07:11 AM

    Hello Sreeram,

     

    Can you double check the Create Process linked to the Custom Object and see if it is causing this issue?

     

    Suhail.



  • 3.  Re: CA 14.2 bug - Save on Subobject initiates the Project's process

    Posted 03-08-2016 07:27 AM

    No the issue is not the create process in the custom object. I've checked the timestamp on it and even the simple SAVE on the custom object triggers the process in the project



  • 4.  Re: CA 14.2 bug - Save on Subobject initiates the Project's process

    Posted 03-08-2016 07:35 AM

    Are there any other processes associated with the custom object? Can you check them?

     

    Suhail.



  • 5.  Re: CA 14.2 bug - Save on Subobject initiates the Project's process

    Posted 03-08-2016 07:41 AM

    There could also be a possibility that a process may have been linked as a sub-process within an another process associated to both the Project object and the custom Sub-object. So, double check on all the processes associated to the Project object as well as the custom Sub-object.

     

    Suhail.