View Only
  • 1.  Load DWH Failure

    Posted Jan 20, 2017 06:22 AM

    We are trying to run the load DWH job (not full load) and we get an error: "error occurred while trying to connect to the database"


    "Login failed for user 'ppm_dwh'."


    However, we are certain that the password for connecting to the database is correct.

    Confirmed it in SQL Studio, the NSA and properties.xml


    We haven't changed the password and it has been working fine but not today unfortunately.

    Can anyone please assist? Thanks.

  • 2.  Re: Load DWH Failure

    Broadcom Employee
    Posted Jan 20, 2017 01:25 PM


    Hi Colin



    Can you ensure that your Database link is working? Also, please run a Full Load every time after an instance of the job fails, this is required in order to populate data from scratch.


    If that doesn't work please provide your bg-dwh logs for review.


    Hope this helps -Nika

  • 3.  Re: Load DWH Failure

    Posted Jan 23, 2017 05:11 AM

    Hi Nika,


    To verify that the DB LINK was working I ran this query against the ppm_dwh schema:


    SELECT count(1) FROM PPMDBLINK.niku.niku.srm_resources


    Data was returned as you can see.


    So I tried running Load DWH again, this time with full load specified, but it immediately failed:





    I can email you my bg_dwh.log file if you need it?

  • 4.  Re: Load DWH Failure

    Broadcom Employee
    Posted Jan 23, 2017 05:22 AM

    Hi Colin,


    The failure error looks to be problematic with the user name to login in DWH, it looks like something is definitely incorrect at the properties.xml



    Suman Pramanik 

  • 5.  Re: Load DWH Failure

    Posted Jan 23, 2017 05:33 AM



    would it be ok for me to send you the details of ppm_dwh extract from our properties.xml file?

  • 6.  Re: Load DWH Failure
    Best Answer

    Posted Jan 23, 2017 09:08 AM

    properties.xml file looked ok and we were able to ping the reporting server from the app server. So we did a quick services restart in the environment and this resolved the issue. Load DWH ran successfully after this.

    Thanks to Suman and Nika for their advice and help.