Clarity

Expand all | Collapse all

Crystal Report Issue

  • 1.  Crystal Report Issue

    Posted 08-11-2015 11:35 AM

    Hi,

     

    I am getting a strange error message when I generate a Crystal Report in Clarity.

    The error says:

     

    "String index out of range: -1"

     

    It is not impacting all reports. Some reports open fine.

    When I check the CMC and Report history it report status says "Success"

     

    All Crystal Report Services are enabled and running.

     

    Has anyone seen this type of behaviour before?



  • 2.  Re: Crystal Report Issue

    Posted 08-18-2015 09:18 AM

    anyone got any updates....?



  • 3.  Re: Crystal Report Issue

    Broadcom Employee
    Posted 08-11-2015 12:16 PM

    Is this happening for out of box report?



  • 4.  Re: Crystal Report Issue

    Posted 08-19-2015 09:07 AM

    1 quick update while investigating.... When we change the default format of crystal report to anything (pdf or excel) other then report, it works fine.

     

    sd.JPG

    But when we give Format option as "Crystal Report" It again gives back the given error as below :-

     

    sd.JPG

     

    Any information on this?



  • 5.  Re: Crystal Report Issue

    Posted 08-12-2015 04:19 AM

    Hi Suman,

     

    no it is happening in some of our custom Crystal Reports. Other custom reports are fine.

    I think the Business Objects, ODBC, services etc are configured correctly. My initial thoughts were that the developers should probably look at the individual troublesome custom reports and compare them to a working custom report, to see if there are any differences. But I said I would check in the communities first to see if others had ever experienced same.



  • 6.  Re: Crystal Report Issue

    Posted 08-20-2015 07:21 AM

    Updating the Tomcat Server helped



  • 7.  Re: Crystal Report Issue

    Posted 08-12-2015 04:47 AM

    Can you try deleting the report definition in Clarity and then creating them again ?

     

    NJ



  • 8.  Re: Crystal Report Issue

    Posted 08-12-2015 07:31 AM

    Hi NJ,

     

    yes I think that is what we are going to try. I will let you know how this goes.



  • 9.  Re: Crystal Report Issue

    Posted 08-12-2015 10:39 AM

    I am also facing same issue.

    It happened after clarity upgrade. Tried Deleting the Definition but no help.

    Report runs fine when run from CR.

    From Clarity it gives error.

     

    Any updates?



  • 10.  Re: Crystal Report Issue

    Posted 08-12-2015 07:44 AM

    Will await the outcome

     

    NJ



  • 11.  Re: Crystal Report Issue

    Posted 08-13-2015 05:45 AM

    We also have tried deleting the definition and recreating but face the same issue.

    There is nothing in the Clarity app logs to indicate any errors. I think as far as Clarity is concerned, the report is generating fine. It is just the Crystal Report where the problem lies.