Clarity

Expand all | Collapse all

CA PPM - Advance Reporting - Jasper Report not displayed

Jump to Best Answer
  • 1.  CA PPM - Advance Reporting - Jasper Report not displayed

    Posted 12-20-2015 11:13 PM

    Currently we are implementing Advance reporting. We have installed and Jaspersoft, DWH and works fine locally.

    We have the problem of “Page not found” when advance reporting is been invoked from CA PPM.

    Below are our setups

    • We have multiple application server each application server has 2 app service
    • multiple application server is load balanced using F5 load balancer
    • Common URL is which is hits the load balancer and channelized based on the load
    • Sticky session is enabled for load balancer
    • 2 CA PPM service in each server is load balanced using  Apache2.0 ModJK [using Apache2.0 due to single sign support]. Sticky session is also enabled over here.
    • Jaspersoft reporting server is installed in separate server

    Below is the page is displayed when we invoke the Advance reporting

     

     

    Also the port on which the Jaspersoft running is not exposed through the Common URL[Used using the load balanced], but can be assessed internally using machine name and port [eg: http://ReportServer:9081/Report].

     

    We also tested the Advance reporting using standalone CA PPM Service and and it works fine.

     

    Appreciate if someone can help on this to resolve the Advance reporting.

     

    Regards

    Balaji



  • 2.  Re: CA PPM - Advance Reporting - Jasper Report not displayed

    Broadcom Employee
    Posted 12-21-2015 02:32 PM

    Hi Balaji,

     

    What is your exact Clarity version?
    Is your HTTPS configured to be handled externally in your properties.xml (what is the value for sslType and enableSSLPort for the app) ? Does the Jaspersoft shows as Available when you go in CSA - Reporting tab?

     

    Please let me know.

     

    Kind Regards

     

    Nika Hadzhikidi
    CA Technologies
    Principal Support Engineer



  • 3.  Re: CA PPM - Advance Reporting - Jasper Report not displayed
    Best Answer

    Posted 12-22-2015 11:22 AM

    Hi Nika,

     

    We are using Clarity 14.2. fix pack 5.

     

    Page not found error is fixed by adding the below statement in the ModJK module of Apache2.0

     

    JkMount /<JasperReport>* <worker>

     

    HTTPS is configured using Apache 2.0 and load balanced using ModJK too hit the CA PPM app service on each server.

    In Properties.xml file will have sslType="external" enableSSLPort="false"

     

    Now I am getting a different issue. When the Advance Reporting is invoked the page looks scrambled and see the error in the application log as

     

    jasper.BaseJasperProcessor (clarity:none:none:none)

    com.niku.union.security.SecurityException: Could not retrieve Session from peristence.

        at com.niku.security.cache.UserSessionCache.get(UserSessionCache.java:206)

     

    Thanks

    Balaji



  • 4.  Re: CA PPM - Advance Reporting - Jasper Report not displayed

    Posted 01-05-2016 06:58 AM

    Page scrambled issue got fixed as well. We used the connector port 8009 which was used by Jaspersoft connector port as well. Changed the CA PPM connector port. It worked



  • 5.  Re: CA PPM - Advance Reporting - Jasper Report not displayed

    Posted 01-05-2016 08:52 AM

    Hi Balajim,

     

    I'm very pleased to hear that changing the CA PPM connector port worked. As an FYI to you, we have comprehensive documentation about installing and configuring Advanced Reporting with Jaspersoft that is available here:

     

    https://docops.ca.com/ca-ppm/14-3/installing-and-upgrading/install-and-configure-advanced-reporting-with-jaspersoft

     

    This is an additional resource that you may choose to reference, and it also contains troubleshooting information.

     

    Kind regards,

     

    John W. George