Clarity

Expand all | Collapse all

Clarity V14.3 upgrade failed

Jump to Best Answer
  • 1.  Clarity V14.3 upgrade failed

    Posted 10-28-2015 01:55 AM

    Hi.

     

    I tried upgrading from clarity V13.3 to 14..3 and it failed after 14.1. I have attached the check install log files. Please suggest what went wrong.

    Also is creating the Database schema for the Data-warehouse feature is mandatory for clarity upgrade?

     

    Clarity Version:Clarity 13.3 01 286

    DB: MS SQL Server 2012

     

    Thanks,

    Shiva

    Attachment(s)

    zip
    install.log.zip   40 KB 1 version


  • 2.  Re: Clarity V14.3 upgrade failed
    Best Answer

    Broadcom Employee
    Posted 10-28-2015 07:16 AM

    Hi Shiva,

     

    Your upgrade is failing due to wrong Java environment  variable set up

     

    10/27/15 7:15 AM (SetupUtil) J2SDK 1.8 Home Directory [C:\Java\jdk1.7.0_25] :

     

    And it fails

     

    10/27/15 7:19 AM (Echo) C:\V14_3\install-packages\14.1.0\upgrade-repack.14.1.0.431tpexcludes\gateway.xml:24: FAILURE: INCORRECT JAVA VERSION

    10/27/15 7:19 AM (Echo)       ------------------------------------------------------

    10/27/15 7:19 AM (Echo)       You are running with Java version 25.40-b25.

    10/27/15 7:19 AM (Echo)       Niku requires JDK 1.7 (Java 7.0).  Please update

    10/27/15 7:19 AM (Echo)       your JAVA_HOME setting to point to the correct j2sdk

    10/27/15 7:19 AM (Echo)       directory and try again.

    10/27/15 7:19 AM (Echo)       --------------------------------

     

    Please correct the Java and then install again.

     

    Regards

    Suman Pramanik



  • 3.  Re: Clarity V14.3 upgrade failed

    Posted 10-29-2015 12:38 AM

    Thanks Suman!!

     

    Yes it was Java version causing the issue. I got help from CA Support and completed the upgrade.

     

    Thanks,

    Shiva



  • 4.  Re: Clarity V14.3 upgrade failed

    Broadcom Employee
    Posted 10-28-2015 11:42 AM

    Hi Shiva,

     

     

    on your second question : you don't have to have the DWH database schema prior to the upgrade from 13.3.

    However, after the upgrade, you have to connect one in CSA - Datawarehouse page, in order to be able to install and use Jaspersoft reports. So I would recommend you to prepare and restore your DWH schema any time, and then just configure it at your convenience in CSA after you get to 14.3.

     

    Hope this helps.

    Good luck with your install!

     

    Kind Regards

     

    Nika Hadzhikidi

    CA Technologies

    Principal Support Engineer



  • 5.  Re: Clarity V14.3 upgrade failed

    Posted 10-29-2015 12:40 AM

    Thanks Nika,

     

    I completed the upgrade without setting up DWH schema. CA Support person suggested we can create it after upgrade.

     

    Thanks,

    Shiva