Clarity

Expand all | Collapse all

IE11 Document mode setting Issue

  • 1.  IE11 Document mode setting Issue

    Posted 12-21-2015 11:11 PM

    Hi,

    I had previously raised a question on the IE11 Enterprise mode and Document mode for our version of Clarity (12.1.2 ).

     

    We have the SSO and Non-SSO logins for Clarity and both have been configured to open in Enterprise mode. I know that IE11 is not a supported version for our version of Clarity, but until we upgrade to the newer version which is at least another 6 months away, we will have to try and fix the issue with IE11.

     

    When I open the IE11 Developer using F12 key, I can see the Browser Profile is 'Enterprise' and Document Mode is '5 (Default)'.

    The setting works fine for the Non-SSO URL, but for SSO where we don't specify the any port number in the url, the setting doesn't seem to be working. And not for the strange part, the same setting works fine when the Developer tool is opened

    i.e. using the F12 option. But stops working once the developer is closed.

     

    We have tried various combinations of the Profile and document mode but nothing seems to resolve the issue with the SSO urls.

     

    Anyone got any suggestions for me?

     

    Navigation issues in IE11 while using SSO

    Snippet from the previous thread:

    "We are facing issues when using the scroll option in the TSV's, the first click takes me to the next set of months, but subsequent clicks just gives a screen flicker and shows the period where I initially started.

    Another issue I'm facing is when I have multiple portlets on a page and one of the portlet is maximised and I select a different portlet from the dropdown list on the top right corner, nothing happens. I have to hit F5 or refresh button for the new portlet to load up."

     

     

    -Harrish



  • 2.  Re: IE11 Document mode setting Issue

    Posted 12-22-2015 03:09 AM

    if it's working with developer tools when emulation is on, then it does sound like it's not being put into enterprise mode.

    Which points to the URL rules specified in the enterprise list.

    I'd check the rules that the administrator has built up, you can find the location of your companies site list from this location

     

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode.

     

    go to the site list xml specified and check each entry for your servers. Ensure there is an entry without the port number



  • 3.  Re: IE11 Document mode setting Issue

    Posted 12-22-2015 09:05 PM

    Hi Andrew,

    I did check the settings in the Registry and my server is listed without the port number.

     

    When I open the application using the SSO url, I can see the Enterprise mode icon appearing on the browser.

     

    1. Is there anything different in the browser when the developer tool is opened?

    2. We use WebSphere to load balance across multiple application server instances. Is there anything we need to check on the websphere end to see why the browser behaves differently when port is specified.

    3. Anything else that I need to check in the Enterprise mode?



  • 4.  Re: IE11 Document mode setting Issue

    Posted 12-23-2015 03:47 AM

    since you can see the enterprise mode icon, at least we know the site list is working.

    What rules have been specified though? is it the same as what you tried in developer tools?



  • 5.  Re: IE11 Document mode setting Issue

    Posted 01-05-2016 08:40 PM

    Hi Andrew,

    Yes its the same setting that we see in the developer tool, just that the browser acts differently when the developer tool is opened vs closed.

    Will the app server behave differently when Single sign on is enabled vs disabled? That's the only difference I can see from NSA.



  • 6.  Re: IE11 Document mode setting Issue

    Posted 08-05-2016 12:17 AM

    Hi,

     

    we just upgraded from 13.1 to 14.3 and we have an integration with SSO and we are facing the same issues. were you able to identify the root cause of the issue.

     

    Appreciate your support

     

    Thanks

    Nikunj Jain



  • 7.  Re: IE11 Document mode setting Issue

    Broadcom Employee
    Posted 08-05-2016 04:59 AM

    Hi Nikunj,

     

    If you are using IE 11 then the browser should be set to IE 10 compatibility mode, because PPM is designed that way. We also have it documented in our guides

     

    Internet Explorer

    If you are using Internet Explorer 11 with CA PPM, the browser is automatically set to run in the

    Internet Explorer 10 compatibility mode for the CA PPM session. The setting is for the CA PPM

    session only and does not affect any other Internet Explorer 11 browser activity. With this release,

    Internet Explorer 8 and 9 are no longer supported.

     

    Regards

    Suman Pramanik



  • 8.  Re: IE11 Document mode setting Issue

    Posted 10-24-2018 12:02 PM

    Hi Suman,

    Is this holds true to Clarity 15.4 as well .We have recently upgraded to 15.4 from 14.3.

    Our Desktop support team has noticed that the there is a hard coded header that overrides browser settings, and forces Clarity to open in IE10 compatibility mode while opening in IE11.

     

    Looking at the Clarity Application URL and using debugger, there is a meta header hard coded to open in IE10 (compatibility mode).

       http-equiv="X-UA-Compatible" content="IE=EmulateIE10

     

    Is there any impact of this on clarity 15.4 features.

     

    Thanks.

    Ritesh