Clarity

Expand all | Collapse all

CA PPM does not want to start with port 80

  • 1.  CA PPM does not want to start with port 80

    Posted 04-15-2015 01:54 AM

    Hello,

     

    we installed a new instance of CA PPM version: 14.2.0.237

     

    And after setting the DB connection and start of PPM we were not able to connect to the application. In app-ca.log we found out following:

     

    SYS   2015-04-14 01:04:21,032 [localhost-startStop-1] niku.union (none:none:none:none) JDBC Driver vendor     : DataDirect^M

    SYS   2015-04-14 01:04:21,033 [localhost-startStop-1] niku.union (none:none:none:none) JDBC Driver name       : Oracle^M

    SYS   2015-04-14 01:04:21,035 [localhost-startStop-1] niku.union (none:none:none:none) JDBC Driver version    : 5.1.1.000103 (F000116.U000049)^M

    SYS   2015-04-14 01:04:21,035 [localhost-startStop-1] niku.union (none:none:none:none) DB product name        : Oracle^M

    SYS   2015-04-14 01:04:21,035 [localhost-startStop-1] niku.union (none:none:none:none) DB product version     : 11.2.0.4.0^M

    SYS   2015-04-14 01:04:21,036 [localhost-startStop-1] niku.union (none:none:none:none) DB user                : PPM^M

    SYS   2015-04-14 01:04:21,046 [localhost-startStop-1] niku.union (none:none:none:none) Starting Cache Messenger...^M

    SYS   2015-04-14 01:04:21,713 [localhost-startStop-1] niku.union (none:none:none:none) Initializing: wmd-init...^M

    SYS   2015-04-14 01:04:21,770 [localhost-startStop-1] niku.union (none:none:none:none) Initializing: odf.init...^M

    SYS   2015-04-14 01:04:36,153 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing: bpm...^M

    SYS   2015-04-14 01:04:36,153 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing Event Manager on server instance: app^M

    SYS   2015-04-14 01:04:36,164 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Broadcasting application service startup signal...^M

    SYS   2015-04-14 01:04:36,166 [Event Interest Registration Thread] niku.union (clarity:none:none:none) Registering event interests...^M

    SYS   2015-04-14 01:04:36,171 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing: bpm-validation...^M

    SYS   2015-04-14 01:04:36,171 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing: njs...^M

    SYS   2015-04-14 01:04:36,174 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing: schedulers.init...^M

    SYS   2015-04-14 01:04:36,190 [localhost-startStop-1] niku.union (clarity:unknown:-1:none) Initializing: tower...^M

     

    And it stuck in this.

     

    We tried to install the CA PPM again and set port 9080 instead of standard 80. After this change it works fine now.

     

    Have someone met same problem? Have you got any idea how to solve this to let run CA PPM with port 80?

     

    Regards,

    Martin



  • 2.  Re: CA PPM does not want to start with port 80

    Broadcom Employee
    Posted 04-15-2015 02:10 AM

    Hi Msnizek,

     

    Can you please stop the clarity and check if the port is used by any other services.

     

    Regards

    Suman Pramanik



  • 3.  Re: CA PPM does not want to start with port 80

    Posted 04-15-2015 04:00 AM

    Running IIS usually takes preference on port 80.



  • 4.  Re: CA PPM does not want to start with port 80

    Broadcom Employee
    Posted 04-15-2015 04:15 AM

    Yes it does, so please remove the IIS service if possible.

     

    Regards

    Suman Pramanik



  • 5.  Re: CA PPM does not want to start with port 80

    Posted 04-15-2015 10:16 AM

    If another product is running on port 80 you should see an exception in the Clarity log stating "bind address in use". That will confirm what the others have said about having something running on port 80.



  • 6.  Re: CA PPM does not want to start with port 80

    Posted 04-15-2015 11:22 AM

    Yes, in the app-system.log, looking (something) like this:

     

    2015/04/15 10:05:59.321 | Apr 15, 2015 10:05:59 AM org.apache.coyote.AbstractProtocol init

    2015/04/15 10:05:59.324 | INFO: Initializing ProtocolHandler ["http-bio-80"]

    2015/04/15 10:05:59.326 | Apr 15, 2015 10:05:59 AM org.apache.coyote.AbstractProtocol init

    2015/04/15 10:05:59.329 | SEVERE: Failed to initialize end point associated with ProtocolHandler ["http-bio-80"]

    2015/04/15 10:05:59.332 | java.net.BindException: Address already in use: JVM_Bind <null>:80

    2015/04/15 10:05:59.335 |       at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:391)

    2015/04/15 10:05:59.338 |       at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:554)

    2015/04/15 10:05:59.341 |       at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:409)

    2015/04/15 10:05:59.344 |       at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)

     

    The output above in the original post is from the app-ca.log though, so please note that the errors would not show there if you are looking for them.



  • 7.  Re: CA PPM does not want to start with port 80

    Posted 04-15-2015 10:21 AM

    If on windows, before starting the Clarity app services, run the command (from the command prompt): netstat -ano | find /i ":80 " | find /i "listen"

     

    Any results it produces (except for those where the port number is > 80 like 800 or 8000 if you miss the space in the command above, you just want to examine the ones specifically with 80 as the port number) will indicate another application already using that port.  The final number on the row is the 'process id' that you can lookup in Task Manager to identify which application it is (if it's not IIS, maybe it is another like Apache HTTP).

     

    You cannot have more than one application using the same address/port(/protocol) combination, so if you want Clarity to run on port 80 and this is your issue, you will need to reconfigure the other application to use another port number or stop it if you are not using it.

     

    If on unix, then in addition to another service possibly already using the port number, you also have to be aware that port numbers less than 1024 are reserved against normal users and have to be run as the 'root' user.  For a Clarity installation this usually means setting up sudo for your Clarity OS user so that they can run the services 'as root' whilst still being logged on as themselves (this also applies to 'root-less' distributions of Linux/unix).