Clarity

Expand all | Collapse all

14.3 Upgrade getting stuck

  • 1.  14.3 Upgrade getting stuck

    Posted 10-06-2015 09:59 AM

    So we're trying to upgrade a QA environment from 13.3 to 14.3 and the installer seems to hang or get stuck at this point every time I run it:

     

    Previous schema directory: D:\CA\Clarity\upgrade\infrastructure\previousSchema

    Option: filtering on type "^pre-upgrade$"

    Option: -updateHistory=false - update history will not be recorded for this sess

    ion.

    Loading DBDriver file: D:\CA\Clarity\upgrade\database\schema\driver.xml

    Loading DBDriver file: D:\CA\Clarity\upgrade\database\schema\driver.xml

    Current database version is database_20140924_1800

    DBDriver for database_20140919_0726

    Start installation of DBDriver ...

     

    Note: Foreign Keys have been disabled

    Process - pre-upgrade: CLEANUP_CMN_CONFIG.xml

    Process - pre-upgrade: CRV_SEGMENT_TYPES.xml

    Process - pre-upgrade: PREUPGARDE_DELDUP_ODFSUBVIEW_COSTPLANDETAIL_CLRT_74359.xm

    l

    Process - pre-upgrade: PREUPGRADE_CRV_STUFF.xml

    Process - pre-upgrade: SEEDDATA_CMN_LANGUAGES.xml

    Process - pre-upgrade: UPDATE_BPM_ERRORS.xml

    Process - pre-upgrade: UPDATE_CMN_INSTALL_HISTORY.xml

    Process - pre-upgrade: UPDATE_CMN_LOV_OBJECTS.xml

    Process - pre-upgrade: UPDATE_OBSNAMES_SPECIAL_CHARS.xml

    Process - pre-upgrade: make_page_layouts_editable.xml

     

    It hangs there for a good 45 minutes at which point I cancel it and try to re-run it with install force which then fails altogether.

     

    After restoring the database back to a good known version of 13.3 and restoring the Clarity filesystem from backup if I run the installer again it hangs at the exact same spot.

     

    So I'm wondering if anyone else has experienced this - is this normal and is just a step that takes a really really long time which somehow I doubt.



  • 2.  Re: 14.3 Upgrade getting stuck

    Posted 10-06-2015 10:37 AM

    Not answering your question, but just commenting the force install.

    That is not supposed to work in v14. anymore. So if the install does not complete you have roll back. That is something to be prepared for before you launch the install.bat.

    The other thing is that if you upgrade several version in one go and it fails in the last upgrade you still have to go back to square one.

    Doing it in steps would make you roll back just one version.

    The only time I have seen that work was when the install did not start because of not supported db version. After fixing that I could still restart the install.



  • 3.  Re: 14.3 Upgrade getting stuck

    Posted 10-06-2015 11:12 AM

    It took also ages for me to progress some installation parts.

    and yes.. "force" is disable... so I already repeated upgrade 4 times...from 13.2.0.9 to 14.3.0

    It fails when 14.1 to 14.2....

     

    then.. rollback all... and start from scratch...

     

     

    If after 2 hour or so.. it does not progress.. then.. yes, it does not look.



  • 4.  Re: 14.3 Upgrade getting stuck

    Posted 10-06-2015 11:13 AM

    or.. I forgot to mention.. force / resume dont work anymore.. but clarity tells you to use them in cmd messages... that should be fixed



  • 5.  Re: 14.3 Upgrade getting stuck

    Posted 10-06-2015 04:17 PM

    Support says that step may take "several hours" based on the amount of data in the database.

     

    I'll let it run for a while and check it periodically but I've never done an upgrade that took that long - maybe 30-40 minutes on a step but never several hours, so we'll see.



  • 6.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 04:51 AM

    I remember when I first tried to upgrade our Sandbox (13.1) to version 14.2 being surprised at how long it took. (7 hours roughly)

    Like you, I initially thought something was wrong as the installation script seemed to stall for a very long time at certain points during the installation.

     

    But it just seems to be the case that it needs this amount of time to complete.



  • 7.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 07:31 AM

    I let it run overnight and it is STILL stuck on the same step.   The performance monitor shows virtually 0% CPU.  This isn't normal, especially where it is in the upgrade process.  I've worked with Clarity for many years and upgrades have always been horrible but this is ridiculous.   This is expensive software.  It shouldn't feel like something some high school kid wrote in his parents basement one night.

     

    I will see what support says, but I'm not confident.



  • 8.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 10:16 AM

    Hi Robert,

     

    I understand your concern: and yes, getting stuck as long as this is definitely not normal.

    Sometimes some of the executing install targets can take more time than usual for specific customers, because of the amount of data they have. However when it takes hours, this is something we should look into resolving. Please let me check your Support case and I'll get back to you with my findings. Please note that this kind of issues happen rarely, and are usually having a very specific root cause. Hopefully we should be able to address this for you.

     

    Kind Regards

     

    Nika Hadzhikidi

    CA Technologies

    Principal Support Engineer



  • 9.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 10:19 AM

    Thank Nika.  I just posted that it was a SQL blocking issue caused by BusinessObjects that seemed to be the culprit.  Wouldn't have thought to check that since this is a QA environment and nobody is running reports but we cleared those connections and the installer got past the part that was causing issues.  I am running it now and it hasn't finished yet, so can't say for certain it will be totally successful but at least that issue seems resolved.



  • 10.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 10:23 AM

    Great to hear it's solved, thanks for letting us know Robert. Please keep me updated on how the upgrade goes!



  • 11.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 10:17 AM

    So turns out there was a SQL block by the BusinesObjects server.  Not sure why since nobody was really using reports in the QA environment but once we cleared those connections the installer whizzed past the place it was getting stuck.

     

    Too bad the installer doesn't give any feedback to indicate a SQL bottleneck like that.

     

    Also might be a good idea for the installation documentation to recommend stopping BO if it's running just to avoid the issue for future upgrades.



  • 12.  Re: 14.3 Upgrade getting stuck

    Posted 10-07-2015 01:00 PM

    How did you find it?



  • 13.  Re: 14.3 Upgrade getting stuck

    Posted 10-09-2015 08:31 PM

    Hi Robert - We're you able to successfully finish the upgrade? Thanks! Chris