Clarity

Expand all | Collapse all

Installing Jaspersoft on Oracle 12.1.0.2 Database

  • 1.  Installing Jaspersoft on Oracle 12.1.0.2 Database

    Posted 12-08-2015 04:31 PM

    Has anyone tried installing Jaspersoft on an Oracle 12.1.0.2 database?  We are getting an ORA-1017 invalid password error when we try to run the install.  We have verified that the info we are entering is correct and are able to connect to the database via SQL Developer.

     

    We have seen that the 14.3 installer had issues with the 12.1.0.2 database too. The install check would fail even though the database was a supported version.

     

    I think CA has some issues recognizing that oracle 12.1.0.2 is supported in their installer.

     

    Any assistance would be appreciated.



  • 2.  Re: Installing Jaspersoft on Oracle 12.1.0.2 Database

    Broadcom Employee
    Posted 12-08-2015 05:51 PM

    Hi,

     

    You might be running into a known defect with the JDBC third party drivers for Oracle (CLRT-79361). It's an intermittent issue that can affect different Oracle releases, not only 12c.


    To workaround this, please do the following:

     

    1. Navigate to %jaspersoft-folder%/libs/c-oracle.jar file

    2. Replace the c-oracle.jar from CA PPM 14.3 $clarity/lib or $install/checkinstall/tools/lib (for the record, the CA PPM version should be 14.2 and higher)

    3. Rerun the Install/Upgrade of Jaspersoft

     

    This should work, please let me know how it goes.

     

    Kind Regards

     

    Nika Hadzhikidi
    CA Technologies
    Principal Support Engineer



  • 3.  Re: Installing Jaspersoft on Oracle 12.1.0.2 Database

    Broadcom Employee
    Posted 12-09-2015 01:55 AM

    Also take a take a look the technical document which we wrote

     

     

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1347126.aspx

     

     

    Regards

    Suman Pramanik