Symantec IGA

Expand all | Collapse all

Java version is incompatible. Please run this converter with Java 1.5 installed.

Jump to Best Answer
  • 1.  Java version is incompatible. Please run this converter with Java 1.5 installed.

    Posted 04-19-2018 12:20 PM

    Hello Guys, how are you ?

     

    I have issues with the java version of the Client tool from the Governance (14.1). This error appeared when I try to initiate the connection to the CA IDM to import objects. 

    My Governance is the standalone version.

     

    The error:

     

     

     

    What I already did:

     

    1) Installed java 1.6 release 23 (64 bits);

    2) Adjusted the Java path and Java Home;

    3) Ran the command: caimport.exe -Xms128m -Xmx1024m -cp "..\lib\ca-connector-api.jar;..\lib\ca-connector-endpoints-common.jar;..\lib\ca-connector-informix.jar;..\lib\ca-connector-os400.jar;..\lib\ca-connector-teradata.jar;..\lib\ca-connector.jar;..\lib\eurekify-api.jar;..\lib\eurekify-common.jar;..\lib\opencsv-2.2.jar;" importfromca.ImportFromCa "SERVER" "20389" "im" "False" "20390" "etaadmin" "**********" TEST 

    I tried to set the log level, however, I didn't find the correct configuration for that.

     

    someone knows how can i fix this issue ?



  • 2.  Re: Java version is incompatible. Please run this converter with Java 1.5 installed.
    Best Answer

    Posted 04-19-2018 01:39 PM

    Ok, i found the solution.

     

    The problem here is the windows has a copy of the java.exe, javaw.exe and  javaws.exe in windows/system32!!! When I installed the Java 1.6, it isn't enough only set the Path variables, it is necessary change in two more places:

     

     

    and remove all java* in the c:\windows\system32.

     

    After, i was able to connect!

     

    Thanks!