Symantec IGA

Expand all | Collapse all

Connector Server Bundle builder issue

Jump to Best Answer
  • 1.  Connector Server Bundle builder issue

    Posted 11-15-2016 10:04 PM

    I have a custom connector(Web Service) based deployeed in 12.5 sp12 and now we are upgrading to IDM 12.6.8

     

    I followed the steps for Deploying connector however, i see the below error

     

    java.lang.Exception: Java Runtime used does not support java compilation

            at com.ca.jcs.osgi.bundletool.ConnectorClassFactoryCreator.runJavaCompil

    er(ConnectorClassFactoryCreator.java:214)

            at com.ca.jcs.osgi.bundletool.ConnectorClassFactoryCreator.doCompile(Con

    nectorClassFactoryCreator.java:192)

            at com.ca.jcs.osgi.bundletool.ConnectorClassFactoryCreator.createAndComp

    ileClassFactory(ConnectorClassFactoryCreator.java:73)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.buildConnectorBundle(BundleB

    uilder.java:214)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.run(BundleBuilder.java:163)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.main(BundleBuilder.java:97)

    java.lang.Exception: Failed to compile: D:\CA\Identity Manager\Connector Server\

    jcs\tools\bundle_builder\INTSSSConnectorClassFactory2927858366817315873.java Com

    pile status: ERROR

            at com.ca.jcs.osgi.bundletool.ConnectorClassFactoryCreator.createAndComp

    ileClassFactory(ConnectorClassFactoryCreator.java:84)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.buildConnectorBundle(BundleB

    uilder.java:214)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.run(BundleBuilder.java:163)

            at com.ca.jcs.osgi.bundletool.BundleBuilder.main(BundleBuilder.java:97)

     

     

    Advise



  • 2.  Re: Connector Server Bundle builder issue
    Best Answer

    Posted 06-15-2017 11:33 AM

    We have informed Engineering about this problem already.

     

    The bundle_builder.bat file by default is pointing to the jvm embedded within the Connector Server under C:\Program Files (x86)\CA\Identity Manager\Connector Server\jvm\bin but the embedded jvm under the Connector Server is not a full jdk (i.e. I do not see any javac.exe in there) and if I do a "java -version" under there I see:

     

    java version "1.8.0_60"
    Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
    Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

     

    I would suggest installing the same JDK 1.8.0_60 version on the machine which is the version of the embedded jvm within the Connector Server and then update the bundle_builder.bat to point to the java of that installed JDK 1.8.0_60 instead of pointing to embedded jvm to resolve your problem for now.